POJ:Multiplication Puzzle

总时间限制: 
1000ms
 
内存限制: 
65536kB
描述
The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.
输入
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
输出
Output must contain a single integer - the minimal score.
样例输入
6
10 1 50 50 20 5
样例输出
3650
来源
Northeastern Europe 2001, Far-Eastern Subregion
状态:
d[i][j]表示第i个数到第j个数合并的最小值
 
状态转移方程:
 
d[i][j]=min(d[i][j],d[i][k]+d[k][j]+a[i]*a[j]*a[k])
i<k<j 

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<cmath>
#include<algorithm>
const int INF = 0x3f3f3f3f;
using namespace std;


int main()
{
    int N, data[105];
    int dp[105][105];
    memset(dp, 0, sizeof dp);
    scanf("%d", &N);
    for (int i = 1; i <= N; i++)
        scanf("%d", &data[i]);
    for (int a = 2; a <= N-1; a++){
        for (int i = 1; i <= N - a; i++){
            int j = i + a;
            dp[i][j] = INF;
            for (int k = i + 1; k < j; k++){
                dp[i][j] = min(dp[i][j], data[i] * data[k] * data[j] + dp[i][k] + dp[k][j]);

            }
        }
        
    }
    printf("%d", dp[1][N]);

    return 0;
}

 

posted on 2018-12-03 23:51  zhouyuepku  阅读(225)  评论(0编辑  收藏  举报