Problem Description

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

Output

If kiki wins the game printf "Wonderful!", else "What a pity!".

Sample Input

5 3

5 4

6 6

0 0

Sample Output

What a pity!

Wonderful!

Wonderful!

 

/*

    看了下网上几乎没有好点的解释,我就献丑下了

    首先证明两个数都是奇数的时候kiki必败,kiki怎么走,zz就怎么走,zz必胜

    然后证明其他的就简单了,kiki第一步走到 a,b都是奇数处,zz就必败了

*/

#include <iostream>

using namespace std;

void main()

{

int a,b;

for (;cin>>a>>b && (a||b);)

{

if (a&b&1)

cout<<"What a pity!\n";

else cout<<"Wonderful!\n";

}

}