hdu3555 Bomb(数位dp)

题目传送门

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 23059    Accepted Submission(s): 8673

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 
Output
For each test case, output an integer indicating the final points of the power.
 
Sample Input
3 1 50 500
 
Sample Output
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 
Author
fatboy_cw@WHU
 
Source
 
代码:
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define mod 1000000007
ll n,m;
ll dp[25][3];
int bit[25];
void init()
{
    //dp初始值
    dp[0][0]=1;
    dp[0][1]=dp[0][2]=0;
    for(int i=1;i<=20;i++)
    {
        dp[i][0]=dp[i-1][0]*10-dp[i-1][1];//除去49
        dp[i][1]=dp[i-1][0];//首位为9
        dp[i][2]=dp[i-1][2]*10+dp[i-1][1];//
    }
}
ll solve(ll a)
{
    int len=0;
    while(a!=0)
    {
        bit[++len]=a%10;
        a/=10;
    }
    bit[len+1]=0;//防止越位
    ll ans=0;
    bool flag=false;
    for(int i=len;i>=1;i--)
    {
        ans+=dp[i-1][2]*bit[i];
        if(flag) ans+=dp[i-1][0]*bit[i];
        if(!flag&&bit[i]>4) ans+=dp[i-1][1];
        if(bit[i+1]==4&&bit[i]==9)flag=true;
    }
    if(flag)ans++;//加上a
    return ans;
}
int main()
{
    ios_base::sync_with_stdio(0);
    cin.tie(0);
    init();
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n;
        cout<<solve(n)<<endl;
    }
    return 0;
}

 

 

Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:  3554 3556 3557 3558 3559 
posted @ 2018-08-23 22:58  better46  阅读(120)  评论(0编辑  收藏  举报