Catch That Cow--POJ3278

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 
求n到k需要多少步变化有(n+1,n-1,n*2)三种选择;
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<queue>
#include<algorithm>
using namespace std;
#define INF 0xfffffff
#define N 100010

int m,n;
int vis[N];
struct node
{
    int x,step;
    friend bool operator<(node a,node b)
    {
        return a.step>b.step;
    }
};

int dfs()
{
    priority_queue<node>Q;
    memset(vis,0,sizeof(vis));
    node q,s;
    s.x=n;
    vis[s.x]=1;
    s.step=0;
    Q.push(s);
    int i;
    while(!Q.empty())
    {
        q=Q.top();
        Q.pop();
        if(q.x==m)
                return q.step;
        for(i=0;i<3;i++)
        {
            if(i==0)
                s.x=q.x+1;
            else if(i==1)
                s.x=q.x-1;
            else if(i==2)
                s.x=q.x*2;
            if(s.x<100001&&s.x>=0&&vis[s.x]==0)//vis[s.x]==0必须放到后面,-_-被运行错误错了好多次;
            {
                vis[s.x]=1;
                s.step=q.step+1;
                Q.push(s);
            }
            
        }
    }
    return -1;//要有返回值,我也不知道为什么;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(m==n)
        {
            printf("0\n");
            continue;
        }
        int ans;
        ans=dfs();
        printf("%d\n",ans);
    }
    return 0;
}

 

posted @ 2015-05-02 14:02  西瓜不懂柠檬的酸  Views(153)  Comments(0Edit  收藏  举报
levels of contents