2023/08/01

天梯图书阅览室请你编写一个简单的图书借阅统计程序。当读者借书时,管理员输入书号并按下S键,程序开始计时;当读者还书时,管理员输入书号并按下E键,程序结束计时。书号为不超过1000的正整数。当管理员将0作为书号输入时,表示一天工作结束,你的程序应输出当天的读者借书次数和平均阅读时间。

注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有S没有E,或者只有E没有S的纪录,系统应能自动忽略这种无效纪录。另外,题目保证书号是书的唯一标识,同一本书在任何时间区间内只可能被一位读者借阅。

输入格式:
输入在第一行给出一个正整数N(≤10),随后给出N天的纪录。每天的纪录由若干次借阅操作组成,每次操作占一行,格式为:

书号([1, 1000]内的整数) 键值(S或E) 发生时间(hh:mm,其中hh是[0,23]内的整数,mm是[0, 59]内整数)

每一天的纪录保证按时间递增的顺序给出。

输出格式:
对每天的纪录,在一行中输出当天的读者借书次数和平均阅读时间(以分钟为单位的精确到个位的整数时间)。

输入样例:
3
1 S 08:10
2 S 08:35
1 E 10:00
2 E 13:16
0 S 17:00
0 S 17:00
3 E 08:10
1 S 08:20
2 S 09:00
1 E 09:20
0 E 17:00
输出样例:
2 196
0 0
1 60
import java.util.Scanner;
public class Main{
    public static void main(String[] args)
    {
        Scanner sc=new Scanner(System.in);
        int n=sc.nextInt();
        for(int i=0;i<n;i++)
        {
            int no,sum=0,temp=0;
            char now,temp1;
            String s;
            int[][] a=new int[2][1000];
            while(true)
            {
                no=sc.nextInt();
                now=sc.next().charAt(0);
                s=sc.next();
                String[] s1=s.split(":");//以冒号为分割符分割字符串
                int h=Integer.parseInt(s1[0]);
                int m=Integer.parseInt(s1[1]);
                if(no==0)
                {
                    if(temp==0)//借出去的次数为0
                    {
                        System.out.println("0 0");
                    }
                    else
                    {
                        System.out.println(temp+" "+((sum-1)/temp+1));
                    }
                    break;//编号为0就结束这一天
                }
                else if(now=='S')
                {
                    a[0][no]=h*60+m;
                    a[1][no]=1;//标记已经借出去了
                }
                else if(now=='E'&&a[1][no]==1)//归还并且之前已经借出去过
                {
                    temp++;
                    a[1][no]=0;
                    sum+=((h*60+m)-a[0][no]);
                }
            }
        }
    }
}

pta的监测点提示部分错误,但是没查到

然后是两个经典的Java程序部分检测点超时问题,Java本身的弊端,也可能是我不会再简化了

给定两个矩阵A和B,要求你计算它们的乘积矩阵AB。需要注意的是,只有规模匹配的矩阵才可以相乘。即若A有R 
a
​
 行、C 
a
​
 列,B有R 
b
​
 行、C 
b
​
 列,则只有C 
a
​
 与R 
b
​
 相等时,两个矩阵才能相乘。

输入格式:
输入先后给出两个矩阵A和B。对于每个矩阵,首先在一行中给出其行数R和列数C,随后R行,每行给出C个整数,以1个空格分隔,且行首尾没有多余的空格。输入保证两个矩阵的R和C都是正数,并且所有整数的绝对值不超过100。

输出格式:
若输入的两个矩阵的规模是匹配的,则按照输入的格式输出乘积矩阵AB,否则输出Error: Ca != Rb,其中Ca是A的列数,Rb是B的行数。

输入样例1:
2 3
1 2 3
4 5 6
3 4
7 8 9 0
-1 -2 -3 -4
5 6 7 8
输出样例1:
2 4
20 22 24 16
53 58 63 28
输入样例2:
3 2
38 26
43 -5
0 17
3 2
-11 57
99 68
81 72
输出样例2:
Error: 2 != 3
import java.util.Scanner;
public class Main
{
    public static void main(String[] args)
    {
        Scanner sc=new Scanner(System.in);
        int a=sc.nextInt();
        int b=sc.nextInt();
        int[][] m=new int [a][b];
        for(int i=0;i<a;i++)
        {
            for(int j=0;j<b;j++)
            {
                m[i][j]=sc.nextInt();
            }
        }
        int c=sc.nextInt();
        int d=sc.nextInt();
        int[][] n=new int[c][d];
        for(int i=0;i<c;i++)
        {
            for(int j=0;j<d;j++)
            {
                n[i][j]=sc.nextInt();
            }
        }
        if(b==c)
        {
        System.out.println(a+" "+d);
        int[][] x=new int[a][d];
        for(int i=0;i<a;i++)
        {
            for(int j=0;j<d;j++)
            {
                for(int k=0;k<b;k++)
                {
                       x[i][j]+=m[i][k]*n[k][j];
                }
            }
        }
        for(int i=0;i<a;i++)
        {
            int k=0;
            for(int j=0;j<d;j++)
            {
                if(k!=0)
                {
                    System.out.print(" ");
                }
                System.out.print(x[i][j]);
                k++;
            }
            System.out.println();
        }
        }
        else
        {
            System.out.println("Error: "+b+" != "+c);
         }
    }
}
一群人坐在一起,每人猜一个 100 以内的数,谁的数字最接近大家平均数的一半就赢。本题就要求你找出其中的赢家。

输入格式:
输入在第一行给出一个正整数N(≤10 
4
 )。随后 N 行,每行给出一个玩家的名字(由不超过8个英文字母组成的字符串)和其猜的正整数(≤ 100)。

输出格式:
在一行中顺序输出:大家平均数的一半(只输出整数部分)、赢家的名字,其间以空格分隔。题目保证赢家是唯一的。

输入样例:
7
Bob 35
Amy 28
James 98
Alice 11
Jack 45
Smith 33
Chris 62
输出样例:
22 Amy
import java.util.Scanner;
public class Main
{
    public static void main(String[]args)
    {
        Scanner sc=new Scanner(System.in);
        int n=sc.nextInt();
        String name[]=new String[n];
        int[] num=new int[n];
        int ave=0;
        for(int i=0;i<n;i++)
        {
            name[i]=sc.next();
            num[i]=sc.nextInt();
            ave+=num[i];
        }
        ave=(int)(ave/n+0.5)/2;//四舍五入
        int x=0,y=Math.abs(num[0]-ave);
        for(int i=1;i<n;i++)
        {
            if(Math.abs(num[i]-ave)<y)
            {
                y=Math.abs(num[i]-ave);
                x=i;
            }
        }
        System.out.println(ave+" "+name[x]); 
    }
}

 

posted @ 2023-08-01 19:06  伐木工熊大  阅读(24)  评论(0编辑  收藏  举报