LA 3177 UVA 1335 - Beijing Guards

Time limit: 3.000 seconds

Beijing was once surrounded by four rings of city walls: the Forbidden City Wall, the Imperial City Wall, the Inner City Wall, and finally the Outer City Wall. Most of these walls were demolished in the 50s and 60s to make way for roads. The walls were protected by guard towers, and there was a guard living in each tower. The wall can be considered to be a large ring, where every guard tower has exaetly two neighbors.

The guard had to keep an eye on his section of the wall all day, so he had to stay in the tower. This is a very boring job, thus it is important to keep the guards motivated. The best way to motivate a guard is to give him lots of awards. There are several different types of awards that can be given: the Distinguished Service Award, the Nicest Uniform Award, the Master Guard Award, the Superior Eyesight Award, etc. The Central Department of City Guards determined how many awards have to be given to each of the guards. An award can be given to more than one guard. However, you have to pay attention to one thing: you should not give the same award to two neighbors, since a guard cannot be proud of his award if his neighbor already has this award. The task is to write a program that determines how many different types of awards are required to keep all the guards motivated.

 

Input 

The input contains several blocks of test eases. Each case begins with a line containing a single integer l$ \le$n$ \le$100000, the number of guard towers. The next n lines correspond to the n guards: each line contains an integer, the number of awards the guard requires. Each guard requires at least 1, and at most l00000 awards. Guard i and i + 1 are neighbors, they cannot receive the same award. The first guard and the last guard are also neighbors.

The input is terminated by a block with n = 0.

 

Output 

For each test case, you have to output a line containing a single integer, the minimum number x of award types that allows us to motivate the guards. That is, if we have x types of awards, then we can give as many awards to each guard as he requires, and we can do it in such a way that the same type of award is not given to neighboring guards. A guard can receive only one award from each type.

 

Sample Input 

 

3
4
2
2
5
2
2
2
2
2
5
1
1
1
1
1
0

 

Sample Output 

 

8
5
3

题目大意:n个人围成圈,第i个人想要ri种礼物,相邻两个人不能有相同的礼物,问至少需要多少礼物才可满足。每种礼物无限多个。

偶数的情况就是相邻的两个ri想加的最大值 。
奇数的情况:二分答案,若有p种礼物,策略为 第一个取 1--r1,奇数的尽量往往后取,偶数的尽量往前取。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
#include <map>
#include <set>

using namespace std;

#ifdef WIN
typedef __int64 LL;
#define form "%I64d\n"
#else
typedef long long LL;
#define form "%lld\n"
#endif

#define SI(a) scanf("%d", &(a))
#define S64I scanf(form, &a)
#define SS(a) scanf("%s", (a))
#define SC(a) scanf("%c", &(a))
#define PI(a) printf("%d\n", a)
#define P64I(a) printf(form, a)
#define Max(a, b) (a > b ? a : b)
#define Min(a, b) (a < b ? a : b)
#define MSET(a, b) (memset(a, b, sizeof(a)))
#define Mid(L, R) (L + (R - L)/2)


const int maxn = 100000 + 50;
int A[maxn];
int left[maxn], right[maxn];
int n;

int ok(int p) {
	left[1] = A[1];
	right[1] = 0;
	for(int i=2; i<=n; i++) {
		if(i & 1) {
			int ts = p-A[1] - right[i-1];
			right[i] = Min(ts, A[i]);
			left[i] = A[i] - right[i];
			if(left[i] + left[i-1] > A[1]) return 0;
		} else {
			int ts = A[1] - left[i-1];
			left[i] = Min(ts, A[i]);
			right[i] = A[i] - left[i];
			if(right[i] + right[i-1]> p - A[1]) return 0;
		} 
	}
	return left[n] < 1;
}

int main() {
	while(SI(n) == 1 && n) {
		LL _sum = 0, _maxa = 0;
		for(int i=1; i<=n; i++) {
			SI(A[i]);
			_sum += A[i];
			_maxa = Max(_maxa, A[i]);
		}
		int ans = 0;
		if(n&1) {
			LL L = _maxa, R = _sum;
			while(L < R) {
				int M = Mid(L, R);
				if(ok(M))
					R = M;
				else
					L = M + 1;
			}
			ans = L;
		} else {
			ans = A[1] + A[n];
			for(int i=1; i<n; i++) if(A[i] + A[i+1] > ans)
				ans = A[i] + A[i+1];
		}
		
		PI(ans);	
	}

	return 0;
}

 








posted on 2013-08-15 09:00  zhaosdfa  阅读(296)  评论(0编辑  收藏  举报

导航