扩大
缩小

NYOJ217a letter and a number

a letter and a number

时间限制:3000 ms  |  内存限制:65535 KB
难度:1
 
描述
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 
输入
On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出
for each case, you should the result of y+f(x) on a line
样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3
样例输出
19
18
10
-17
-14
-4
 

#include<stdio.h>
#include<string.h>
int main()
{
    int n,x,b;
    char a;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        scanf("%c %d",&a,&b);
        getchar();
        if(a>='A'&&a<='Z')
            printf("%d\n",a-'A'+1+b);
        else if(a>='a'&&a<='z')
            printf("%d\n",-(a-'a'+1)+b);
    }
    return 0;
}

                
        

 

posted on 2012-08-02 14:37  LinuxPanda  阅读(186)  评论(0编辑  收藏  举报

导航