nyoj113字符串替换

字符串替换

时间限制:3000 ms  |  内存限制:65535 KB
难度:2
 
描述
编写一个程序实现将字符串中的所有"you"替换成"we"
 
输入
输入包含多行数据 

每行数据是一个字符串,长度不超过1000 
数据以EOF结束
输出
对于输入的每一行,输出替换后的字符串
样例输入
you are what you do
样例输出
we are what we do
View Code
 
#include<stdio.h>
#include<string.h>
char stra[1010],strb[1010];
int main()
{
    int i,j;
    while(gets(stra))
    {
        j=0;
        for(i=0;stra[i]!='\0';i++)
            if(stra[i]=='y'&&stra[i+1]=='o'&&stra[i+2]=='u')
            {
                strb[j++]='w';
                strb[j++]='e';
                i=i+2;
            }
            else 
            {
                strb[j++]=stra[i];
            }
        strb[j]='\0';
        printf("%s\n",strb);
    }
    return 0;
}
        
        

 

posted @ 2012-07-27 21:41  赵杰迪!  阅读(107)  评论(0编辑  收藏  举报