zoj 3819(牡丹江现场赛A题)

马上要去上海了,刷刷现场赛的题找找感觉~~~

这题。。。。。。。额,没什么好说的,太水。。

ZOJ Problem Set - 3819
Average Score

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

"Too bad! You made me so disappointed."

"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

Now, you are given the scores of all students in the two classes, except for the Bob's. Please calculate the possible range of Bob's score. All scores shall be integers within [0, 100].

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob's class and the number of students in the other class respectively.

The next line contains N - 1 integers A1, A2, .., AN-1 representing the scores of other students in Bob's class.

The last line contains M integers B1, B2, .., BM representing the scores of students in the other class.

Output

For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

It is guaranteed that the solution always exists.

Sample Input

2
4 3
5 5 5
4 4 3
6 5
5 5 4 5 3
1 3 2 2 1

Sample Output

4 4
2
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <math.h>
#include <algorithm>
#include <vector>
#include <map>
#include <queue>
#include <stack>
#define PI acos(-1.0)
#define eps 1e-6
#define LL long long
#define moo 31536000
#define INF 1e9
#define maxn 100010
#define e exp(1.0)
using namespace std;
int main()
{
    int n,m,i,T;
    double ave1,ave2;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        ave1=ave2=0.0;
        for(i=1;i<n;i++)
        {
            int tp;
            scanf("%d",&tp);
            ave1+=tp;
        }
        ave1/=n-1;
        for(i=0;i<m;i++)
        {
            int tp;
            scanf("%d",&tp);
            ave2+=tp;
        }
        ave2/=m;
        int i;
        for(i=0;i<=ave2;i++); //虽然很水,但是这个地方还是要想想的~
        printf("%d ",i);
        for(;i<ave1;i++);
            printf("%d\n",i-1);
    }
    return 0;
}




posted on 2014-11-22 20:47  胖胖的乓乓  阅读(118)  评论(0编辑  收藏  举报

导航