poj 1274 (二分匹配)

The Perfect Stall
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 20863   Accepted: 9417

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

Sample Output

4

Source





[Submit]   [Go Back]   [Status]   [Discuss]



//有n个奶牛和m个谷仓,现在每个奶牛有自己喜欢去的谷仓,并且它们只会去自己喜欢的谷仓吃东西,问最多有多少奶牛可以呆在自己喜欢的谷仓
//裸的二分匹配,求最大匹配数
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <map>
#include <stack>
#include <set>
#include <cmath>
#include <vector>
#include<cstdlib>
#define INF 0x3f
#define eps 1e-6
#pragma comment (linker,"/STACK:102400000,102400000")
using namespace std;
#define maxn 255
int n,m;
int nx,ny;
int vis[maxn];
int g[maxn][maxn];
int cx[maxn];
int cy[maxn];
int path(int u)
{
    for(int v=1;v<=ny;v++)
    {
        if(g[u][v] && !vis[v])
        {
            vis[v]=1;
            if(cy[v]==-1 || path(cy[v]))
            {
                cx[u]=v;
                cy[v]=u;
                return 1;

            }
        }
    }
    return 0;
}
int max_match()
{
    int res=0;
    memset(cx,-1,sizeof(cx));
    memset(cy,-1,sizeof(cy));
    for(int i=1;i<=nx;i++)
    {
        if(cx[i]==-1)
        {
            memset(vis,0,sizeof(vis));
            res+=path(i);
        }
    }
    return res;
}
int main()
{
    while(~scanf("%d%d",&nx,&ny))
    {
        memset(g,0,sizeof(g));
        for(int i=1;i<=nx;i++)
        {
            int nn;
            scanf("%d",&nn);
            for(int j=1;j<=nn;j++)
            {
                int a;
                scanf("%d",&a);
                g[i][a]=1;
            }
        }
        cout<<max_match()<<endl;
    }
}


posted on 2015-09-09 09:59  胖胖的乓乓  阅读(164)  评论(0编辑  收藏  举报

导航