HDU 1711 Number Sequence

Time Limit: 5000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u

 Status

Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 
 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 
 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 
 

Sample Input

2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output

6 -1
 


思路:裸KMP

<span style="font-size:18px;">#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <set>
#include <vector>
#include<cstdlib>
#include <cmath>
#pragma comment (linker,"/STACK:102400000,102400000")
using namespace std;
#define maxn 1000500
int next_[maxn];
int  str1[maxn];
int  str2[maxn];
int len_1,len_2;
int conut;
void get_next()
{
    int i=0;
    int j=-1;
    next_[i]=j;
    while(i<len_2)
    {
        if(j==-1 || str2[i]==str2[j])
        {
            ++i;
            ++j;
            next_[i]=j;
        }
        else
            j=next_[j];

    }
}
void kmp()
{
    get_next();
    int i=0;
    int j=0;
    int len=len_1;
    while(i<len)
    {
        if(j==-1 || str1[i]==str2[j])
        {
            ++i;
            ++j;
        }
        else
            j=next_[j];
        if(j==len_2)
        {
            cout<<i-len_2+1<<endl;
            return;
        }

    }
    cout<<"-1"<<endl;

}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
         scanf("%d%d",&len_1,&len_2);
        memset(next_,-1,sizeof(next_));
        conut=0;
        for(int i=0;i<len_1;i++) scanf("%d",&str1[i]);
        for(int i=0;i<len_2;i++) scanf("%d",&str2[i]);
        kmp();
        //cout<<conut<<endl;
    }
    return 0;
}</span>


posted on 2016-07-12 10:41  胖胖的乓乓  阅读(149)  评论(0编辑  收藏  举报

导航