zoj 3712 Hard to Play

   
Time Limit: 2MS   Memory Limit: 65536KB   64bit IO Format: %lld & %llu

Status

Description

MightyHorse is playing a music game called osu!.

After playing for several months, MightyHorse discovered the way of calculating score in osu!:

1. While playing osu!, player need to click some circles following the rhythm. Each time a player clicks, it will have three different points: 300, 100 and 50, deciding by how clicking timing fits the music.

2. Calculating the score is quite simple. Each time player clicks and gets P points, the total score will add P, which should be calculated according to following formula:

P = Point * (Combo * 2 + 1)

Here Point is the point the player gets (300, 100 or 50) and Combo is the number of consecutive circles the player gets points previously - That means if the player doesn't miss any circle and clicks the ith circle, Comboshould be i - 1.

Recently MightyHorse meets a high-end osu! player. After watching his replay, MightyHorse finds that the game is very hard to play. But he is more interested in another problem: What's the maximum and minimum total score a player can get if he only knows the number of 300, 100 and 50 points the player gets in one play?

As the high-end player plays so well, we can assume that he won't miss any circle while playing osu!; Thus he can get at least 50 point for a circle.

Input

There are multiple test cases.

The first line of input is an integer T (1 ≤ T ≤ 100), indicating the number of test cases.

For each test case, there is only one line contains three integers: A (0 ≤ A ≤ 500) - the number of 300 point he gets, B (0 ≤ B ≤ 500) - the number of 100 point he gets and C (0 ≤ C ≤ 500) - the number of 50 point he gets.

Output

For each test case, output a line contains two integers, describing the minimum and maximum total score the player can get.

Sample Input

1
2 1 1 

Sample Output

2050 3950

   高手玩家得分至少为50。记分公式为P = Point * (Combo * 2 + 1),求最多得多少分,最低得多少分。

   简单的贪心,贪心策略:最高分先50,再100,最后300。最低分反之。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
int A,B,C;
int  t;
int main()
{
    cin>>t;
    while(t--)
    {
        scanf("%d%d%d",&A,&B,&C);
        int maxx=0;
        int minn=0;
        for(int i=0;i<A;i++)
            minn+=300*(i*2+1);
        for(int i=A;i<A+B;i++)
            minn+=100*(i*2+1);
        for(int i=A+B;i<A+B+C;i++)
            minn+=50*(i*2+1);

        for(int i=0;i<C;i++)
            maxx+=50*(i*2+1);
        for(int i=C;i<C+B;i++)
            maxx+=100*(i*2+1);
        for(int i=C+B;i<A+B+C;i++)
            maxx+=300*(i*2+1);

            cout<<minn<<" "<<maxx<<endl;
    }
    return 0;
}



posted on 2016-07-12 11:08  胖胖的乓乓  阅读(164)  评论(0编辑  收藏  举报

导航