点点滴滴”

导航

poj 1806 分块模拟

Manhattan 2025
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 1318   Accepted: 703

Description

Background Manhattan in the year 2025 - it is so densely populated that its old two-dimensional grid of streets and avenues fails to provide enough space for all the traditional vehicles such as cars, bicycles, or busses.Accordingly, the newly developed 3D-Skyjetters become very popular, because they allow to pass the traffic jams on the ground by flying in the air. After a series of horrible accidents caused by 3D-Skyjetters cutting a corner, New York authorities have put into place new regulations of air traffic and are determined to enforce them rigorously. The key point of these regulations is that 3D-Skyjetters must follow virtual airways on a three-dimensional rectangular grid, easy enough for the New Yorkers who had to use the two-dimensional rectangular grid of roads on the ground all their life. Problem You own a company that rents out 3D-Skyjetters. As 3D-Skyjetters are in such an early state of development,they are far from being economical. So your customers keep running out of petrol at all the wrong places,and you need a system to inform them about their current range at all times. You may assume that travelling from one intersection to the next in the grid takes one unit of petrol, no matter if the customer is moving horizontally or vertically, up or down. You may also assume that your customer is located at some intersection where his or her movements are not restricted by the ground or other obstacles, but just by the amount of remaining petrol. Given the amount of petrol, provide a graphical representation of all the intersections in the range of your customer, along with the amount of petrol that is needed to go there.

Input

The first line of the input contains the number of scenarios. For each scenario, there is a line containing the units of remaining petrol, i.e an integer u satisfying 0 <= u <= 9. If more than 9 units of petrol remain, the customer will ignore the display anyway.

Output

Start the output for each scenario with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a graphical (or rather textual) representation of all intersections that can be reached with the given amount of petrol, along with the units of petrol necessary to go there. In this graphical representation, print the slices of the smallest axis-aligned three-dimensional cube containing all the intersections in the range, and label the slices from the bottom to the top starting at 1. For each slice,start the output with a line containing "slice #s:", where s is the number of the slice. In the lines that follow, print a graphical representation of all the intersections in that slice, using 
  • the digits 0 to 9 for intersections in the range, representing the amount of petrol necessary to go there,
  • and the dot "." for intersections not in the range.
Print an additional blank line after each scenario.

Sample Input

2
0
2

Sample Output

Scenario #1:
slice #1:
0

Scenario #2:
slice #1:
.....
.....
..2..
.....
.....
slice #2:
.....
..2..
.212.
..2..
.....
slice #3:
..2..
.212.
21012
.212.
..2..
slice #4:
.....
..2..
.212...2.. ..... slice #5: ..... ..... ..2.. ..... .....

Source

TUD Programming Contest 2003, Darmstadt, Germany
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int Scenario,Oil,Slice,M[30][30];
void Display()
{
    int i,j;
    for (i=0;i<Slice;i++)
    {
        for (j=0;j<Slice;j++)
        {
            if (M[i][j]<=Oil)
                printf("%d",M[i][j]);
            else
                printf(".");
        }
        printf("\n");
    }
}
void left_up(int x,int y,int m,int t)
{
    if (m==Oil+1)
        return;
    M[x][y]=m;
    left_up(x-1,y,m+t,t);
    left_up(x,y-1,m+t,t);

}
void up_right(int x,int y,int m,int t)
{
    if (m==Oil+1)
        return;
    M[x][y]=m;
    up_right(x+1,y,m+t,t);
    up_right(x,y-1,m+t,t);
}
void right_down(int x,int y,int m,int t)
{
    if (m==Oil+1)
        return;
    M[x][y]=m;
    right_down(x+1,y,m+t,t);
    right_down(x,y+1,m+t,t);

}
void down_left(int x,int y,int m,int t)
{
    if (m==Oil+1)
        return;
    M[x][y]=m;
    down_left(x,y+1,m+t,t);
    down_left(x-1,y,m+t,t);
}
void func(int x,int y,int m,int t)
{
    left_up(x,y,m,t);
    up_right(x,y,m,t);
    right_down(x,y,m,t);
    down_left(x,y,m,t);
}
int main()
{
    int i,j,x,y;
    scanf("%d",&Scenario);
    for(i=1;i<=Scenario;i++)
    {
        scanf("%d",&Oil);
        printf("Scenario #%d:\n",i);
        if (Oil==0)
        {
            printf("slice #1:\n0\n");
        }
        else
        {
            Slice=2*Oil+1;
            for (j=0;j<Slice;j++)
            {
                memset(M,10,sizeof(M));
                x=Oil;
                y=Oil;
                printf("slice #%d:\n",j+1);
                if (j<=Oil)
                    func(x,y,Oil-j,1);
                else
                    func(x,y,j-Oil,1);
                Display();
            }
        }
        printf("\n");
    }
    return 0;
}

 注意方位的把握~~~

posted on 2014-09-29 19:22  点点滴滴”  阅读(239)  评论(0编辑  收藏  举报