点点滴滴”

导航

poj 3070

Fibonacci

Time Limit: 1000 MS Memory Limit: 65536 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

#include <iostream>
#include <string.h>
#include <stdio.h>

using namespace std;
#define MOD 10000
int n;

struct mat
{
    int at[2][2];
} d;

mat momu(mat a,mat b)
{
    mat c;
    memset(c.at,0,sizeof(c.at));
    for(int i=0; i<n; i++)
    {
        for(int k=0; k<n; k++)
        {
            if(a.at[i][k])
                for(int j=0; j<n; j++)
                {
                    c.at[i][j]+=a.at[i][k]*b.at[k][j];
                    if(c.at[i][j]>MOD)
                    {
                        c.at[i][j]%=MOD;
                    }
                }
        }
    }
    return c;
}

mat expo(mat p,int k)
{
    if(k==1)
        return p;
    mat e;
    memset(e.at,0,sizeof(e.at));
    for(int i=0; i<n; i++)
        e.at[i][i]=1;
    if(k==0)
        return e;
    while(k)
    {
        if(k&1)
            e=momu(p,e);
        p=momu(p,p);
        k>>=1;
    }
    return e;

}

int main()
{
    n=2;
    d.at[0][0]=1;
    d.at[0][1]=1;
    d.at[1][0]=1;
    d.at[1][1]=0;
    int t;
    while(scanf("%d",&t)!=EOF)
    {
        if(t==-1)
            break;
        mat dd=expo(d,t);
        int ans=dd.at[0][1]%MOD;
        printf("%d\n",ans);
    }
    return 0;
}

约等于模板啦啦啦啦~~~~~~~~~~~

posted on 2014-09-16 19:49  点点滴滴”  阅读(132)  评论(0编辑  收藏  举报