点点滴滴”

导航

poj 1936 All in All

All in All

Time Limit: 1000 MS Memory Limit: 30000 KB

64-bit integer IO format: %I64d , %I64u   Java class name: Main

[Submit] [Status] [Discuss]

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No


题意:第一个串是否是第二个的子串 区分大小写 依旧前几道题暴力的思想

#include <iostream>
#include <string.h>
#include <stdio.h>

using namespace std;

int main()
{
    long long int i,j; ///int会超
    char s1[100000],s2[100000];
    while(scanf("%s",s1)!=EOF)
    {
        scanf("%s",s2);
        long len1=strlen(s1);
        long len2=strlen(s2);
        i=0;
        j=0;
        while(true)
        {
            if(i==len1)
            {
                cout<<"Yes"<<endl;
                break;
            }
            else if(i<len1 && j==len2)
            {
                cout<<"No"<<endl;
                break;
            }
            if(s1[i]==s2[j])
            {
                i++;
                j++;
            }
            else
                j++;
        }
        memset(s1,'\0',sizeof(s1));
        memset(s2,'\0',sizeof(s2));
    }
    return 0;
}

 

posted on 2014-08-31 14:53  点点滴滴”  阅读(180)  评论(0编辑  收藏  举报