点点滴滴”

导航

C - Roll-call in Woop Woop High

Description

Download as PDF

The new principal of Woop Woop High is not satisfied with her pupils performance. She introduced a new roll-call process to get a daily measure of the pupils' learning, which proceeds as follows:

At the beginning of the daily roll-call period each pupil is handed a question, which they must attempt to answer, before proceeding to their classes. A pupil stops after the question is answered correctly. Each pupil is allowed up to five attempts to answer the question correctly.

Pupils who answer correctly on the first attempt are marked present. Pupils who answer correctly after more than one attempt are encouraged to work at home. Pupils who fail to develop a correct answer within five attempts are given remedial classes after school. Pupils who do not give any answer are marked as abscent.

Your task is to write a program that reads the pupils' assessments and generates performance reports for the principal to proceed with appropriate actions.

Input

The input starts with an integer K ( 1$ \le$K$ \le$100) indicating the number of classes. Each class starts with an integer N ( 1$ \le$N$ \le$50) indicating the number of pupils in the class. Each of the following N lines starts with a pupil's name followed by up-to five assessments of his/her answers. An assessment of 'yes' or 'y' indicates a correct answer and an assessment of 'n' or 'no' indicates a wrong answer. A pupil's name consists of a single string with no white spaces.

Output

The attendance report for each class consists of five lines.

  • The first line consists of the sentence: "Roll-call: X", where X indicates the class number starting with the value of one.
  • The second line consists of the sentence: ''Present: Y1 out of N'', where Y1 is the number of pupils who did not submit a wrong answer.
  • The third line consists of the sentence: ''Needs to study at home: Y2 out of N'', where Y2 is the number of pupils who submitted a number of wrong answers before submitting the correct answer.
  • The fourth line consists of the sentence: ''Needs remedial work after school: Y3 out of N'', where Y3 indicates the number of pupils whose submitted five wrong answers.
  • The fifth line consists of the sentence: ''Absent: Y4 out of N'', where Y4 indicates the number of absent pupils.

Sample Input

2
5
Doc n y
sneezy n n no yes
princecharming no n no no n
goofy yes
grumpy n y
5
evilemperor n y
princesslia
r2d2 no no y
obeyonecanopy n no y
darthvedar y

Sample Output

Roll-call: 1
Present: 1 out of 5
Needs to study at home: 3 out of 5
Needs remedial work after school: 1 out of 5
Absent: 0 out of 5
Roll-call: 2
Present: 1 out of 5
Needs to study at home: 3 out of 5
Needs remedial work after school: 0 out of 5
Absent: 1 out of 5
/*
题意:每个人做五道题  答对(yes/y) 答错(n,/n)
      Roll-call: 1   回合
      Present: 1 out of 5   第一道就答对了
      Needs to study at home: 3 out of 5  五道题之内答对了一道  但不是第一道
      Needs remedial work after school: 1 out of 5  五道题都没有答对
      Absent: 0 out of 5   一道题也没有回答


 各种写法都有   不过就还是最熟悉的写法来的好
 读空格 gets()  也可以是读整行的getline--cin.getline(str,100);
 getcahr()  一直不能掌握其要领  不过输入字符串的时候就要注意一下
 */

 #include <iostream>
 #include <string.h>
 #include <stdio.h>

 using namespace std;
 int s1,s2,s3,s4;
 bool OK;
 int cnt;

 int main()
 {
     int t,n;
     int num;
     char str[150];

     scanf("%d",&t);
     for(num=1;num<=t;num++)
     {
         s1=0;s2=0;s3=0;s4=0;

         scanf("%d",&n);
         int s=n;
         getchar();
         while(n--)
         {
              OK=false;
              cnt=0;
              gets(str);
              int len=strlen(str);
              for(int i=0;i<len;i++)
              {
                  if(str[i-1]==' '&&str[i]=='y')
                  {
                      if(cnt==0)  ///yi ci jiu dui
                      s1++;
                      else  ///hui da hao ji ci dui
                      s2++;
                      cnt++;   ///lai guo
                      OK=true;
                  }
                  else if(str[i-1]==' '&&str[i]=='n')
                  {
                      cnt++;  ///lai guo
                  }

              }
              if(cnt==0)
              s4++;   ///mei lai
              else if(!OK)
              s3++;  ///mei dui guo
         }
        // cout<<s1<<' '<<s2<<' '<<s3<<' '<<s4<<endl;
        printf("Roll-call: %d\n",num);
        printf("Present: %d out of %d\n",s1,s);
        printf("Needs to study at home: %d out of %d\n",s2,s);
        printf("Needs remedial work after school: %d out of %d\n",s3,s);
        printf("Absent: %d out of %d\n",s4,s);
     }
 }

 

posted on 2014-08-18 17:08  点点滴滴”  阅读(223)  评论(0编辑  收藏  举报