点点滴滴”

导航

poj 1837 01背包

Balance

Time Limit: 1000 MS Memory Limit: 30000 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2
/*
01背包

题意:C个钩码(2—20) G个物品(2—20) 钩码位置(-25—25) 物品重量(0—20)  物品都用上且天平平衡有多少种方案
 
dp[i][j]:挂前i个物品达到状态j 状态j的取值范围时-25*25*20——25*25*20  所以j取(-7500--7500) 防止出现负值 所以令j==15000  即j==7500时为平衡位置
想~~每次挂砝码都会影响天平的平衡 即状态j  影响因素是力臂=c[i]*w[k] (n,m影响它的取值)    
     挂前i个物品时状态是dp[i-1][j] 则挂第i个物品后状态变为dp[i][j+c[i]*w[k]]  
     假设dp[i-1][j]的值是num  那么  dp[i][j+c[i]*w[k]]也是num 
     即dp[i][j+c[i]*w[k]]+=dp[i-1][j]   前面状态影响后面的  
 
 */
 #include <iostream>
 #include <string.h>
 #include <stdio.h>

 int dp[35][15001]; ///前i个物品达到j的状态有的dp[][]种

 int main()
 {
     int n,m;  ///钩子个数 砝码个数
     int c[35]; ///钩子的位置
     int w[35]; ///砝码重量

     scanf("%d%d",&n,&m);

     for(int i=1;i<=n;i++)
     scanf("%d",&c[i]);
     for(int j=1;j<=m;j++)
     scanf("%d",&w[j]);

     memset(dp,0,sizeof(dp));  
     dp[0][7500]=1;   ///因为防止出现负数情况 所以dp[][1500]了  同时dp[][7500]是平衡状态

     for(int i=1;i<=m;i++)  
     {
         for(int j=0;j<=15000;j++)  
         {
             for(int k=1;k<=n;k++)  
             {
                 dp[i][j+c[k]*w[i]]+=dp[i-1][j]; ///核心  在前面介绍
             }
         }
     }
     printf("%d\n",dp[m][7500]);
 }

 

posted on 2014-08-13 10:40  点点滴滴”  阅读(119)  评论(0编辑  收藏  举报