点点滴滴”

导航

poj 2155 区间更新 单点查询

Matrix

Time Limit: 3000 MS Memory Limit: 65536 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1
#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;
#define max 1005
int c[max][max];
int n;

int lowbit(int x)
{
    return x&-x;
}

void update(int x,int y,int val)
{
    for(int i=x; i<=n; i+=lowbit(i))
    {
        for(int j=y; j<=n; j+=lowbit(j))
        {
            c[i][j]+=val;
        }
    }
}

int get_sum(int x,int y)
{
    int s=0;
    for(int i=x; i>0; i-=lowbit(i))
    {
        for(int j=y; j>0; j-=lowbit(j))
        {
            s+=c[i][j];
        }
    }
    return s;
}

int main()
{
   /// freopen("in.txt","r",stdin);
    ///freopen("out.txt","w",stdout);
   int cc,t,x1,x2,y1,y2,a,b;
    char ch;
    scanf("%d",&cc);
    for(int i=1;i<=cc;i++)
    {
        memset(c,0,sizeof(c));
        scanf("%d%d",&n,&t);
        getchar();
        for(int j=0;j<t;j++)    ///下标不可以从0开始  会死循环
        {
            scanf("%c",&ch);
            if(ch=='C')
            {
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                getchar();
                update(x1,y1,1);
                update(x1,y2+1,1);
                update(x2+1,y1,1);
                update(x2+1,y2+1,1);
            }
            else
            {
                scanf("%d%d",&a,&b);
                getchar();
                printf("%d\n",get_sum(a,b)%2);
            }
        }
        printf("\n");
    }
    return 0;
}

* 矩阵的00在左上角

http://blog.csdn.net/zxy_snow/article/details/6264135   图示

posted on 2014-08-11 09:56  点点滴滴”  阅读(129)  评论(0编辑  收藏  举报