点点滴滴”

导航

poj2828 线段树单点更新

Buy Tickets

Time Limit: 4000 MS Memory Limit: 65536 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

#include <queue>
#include <stack>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <limits.h>
#include <string.h>
#include <string>
#include <algorithm>
#define MID(x,y) ( ( x + y ) >> 1 )
using namespace std;
const int MAX = 200010;
struct Tnode
{
    int l,r,sum;
} node[MAX<<2];

struct NODE
{
    int pos,val;
}a[MAX];

int ind[MAX];
int K;

void update_sum(int root)
{
    node[root].sum = node[root*2+1].sum + node[root*2].sum;  ///空格数
}

void build(int root,int l,int r)
{
    node[root].l = l;
    node[root].r = r;
    node[root].sum = 0;
    if( l == r - 1 )
    {
        node[root].sum = 1;
        return ;
    }
    int mid = MID(l,r);
    build(root*2,l,mid);
    build(root*2+1,mid,r);
    update_sum(root);
}

void update(int root,int l)
{
    if( node[root].l == node[root].r - 1 )
    {
        node[root].sum = 0;  ///没有空格了
        K = node[root].l;  ///标记所在的位置  输出时用
        return ;
    }
    if( l < node[root*2].sum )///当前位置小于左边空位,则查到t的前面
        update(root*2,l);
    else
        update(root*2+1,l-node[root*2].sum);///否则往右边插,但是需要需要减去左边空位。。
    update_sum(root);
}

int main()
{
    int n;
    while( ~scanf("%d",&n) )
    {
       memset(node,0,sizeof(node));

        for(int i=1; i<=n; i++)
            scanf("%d %d",&a[i].pos,&a[i].val);
           build(1,1,n+1);   ///这要注意一下  build(1,1,n)就不对~~~~~
        for(int i=n; i>=1; i--)
        {
            update(1,a[i].pos);
            ind[K] = a[i].val;
        }
        for(int i=1; i<n; i++)
            printf("%d ",ind[i]);
        printf("%d\n",ind[n]);

    }
    return 0;
}

题意讲解  灰常赞

http://www.cnblogs.com/CheeseZH/archive/2012/04/29/2476134.html

posted on 2014-08-08 10:41  点点滴滴”  阅读(96)  评论(0编辑  收藏  举报