点点滴滴”

导航

poj1573模拟

Robot Motion

Time Limit: 1000 MS Memory Limit: 10000 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)
#include<iostream>
#include <string.h>

using namespace std;

int main(void)
{
    int row,col,entry;
    char grid[12][12];     //在规定大小的grid外部至少再定义一圈"门槛"以判断Robot是否离开了grid  (最大grid为10x10)

    for(;;)
    {
        memset(grid,'O',sizeof(grid));     // 'O' 为大写字母O,意为 Out

        /*Input*/

        int i,j;

        cin>>row>>col>>entry;
        if(!(row && col && entry))break;

        for(i=1;i<=row;i++)
            for(j=1;j<=col;j++)
                cin>>grid[i][j];

            /*Judge Robot get out of the grid or starts a loop in the grid*/

            int flag[12][12]={0};   //标记Robot经过某点的次数,当有一点为2则说明Robot陷入了以该点为loop起始点的循环
            int count;
            int r=1;
            int c=entry;
            for(count=0;;count++)
            {
                flag[r][c]++;  //注意顺序,先标记,再位移
                if(grid[r][c]=='N')        //
                    r--;
                else if(grid[r][c]=='S')   //
                    r++;
                else if(grid[r][c]=='W')   //
                    c--;
                else if(grid[r][c]=='E')   //
                    c++;
                else if(grid[r][c]=='O')        // Out
                {
                    cout<<count<<" step(s) to exit"<<endl;
                    break;
                }

                if(flag[r][c]==2)         //loop
                {
                    row=r;           //标记Robot循环起止点
                    col=c;
                    int flg=1;
                    for(r=1,c=entry,count=0;;count++)
                    {
                        if(r==row && c==col && flg==1)  //注意顺序,先寻找循环点再位移(避免Robot刚进入grid就陷入了循环的情况)
                        {
                            cout<<count<<" step(s) before a loop of ";        //输出进入循环前的步数
                            count=0;
                            flg++;
                        }
                        if(r==row && c==col && count!=0 && flg==2)
                        {
                            cout<<count<<" step(s)"<<endl;              //输出循环步数
                            break;
                        }
                        if(grid[r][c]=='N')        //
                            r--;
                        else if(grid[r][c]=='S')   //
                            r++;
                        else if(grid[r][c]=='W')   //
                            c--;
                        else if(grid[r][c]=='E')   //
                            c++;
                    }
                    break;    //跳出count的for循环,不是跳出if(当然break也不能用于跳出if,这里的说明是为了避免误解)
                }
            }
    }
    return 0;
}

题意:按照表格的提示走~~~

        模拟模拟  太恶心啦

http://blog.csdn.net/lyy289065406/article/details/6645434

他的博客真心棒!!!!!

posted on 2014-07-18 17:40  点点滴滴”  阅读(148)  评论(0编辑  收藏  举报