点点滴滴”

导航

poj1068 模拟

 

Parencodings

Time Limit: 1000 MS Memory Limit: 10000 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9



#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stack>

using namespace std;

int main()
{
    int t,n,temp;
    int a[1000];
    int val[1000],w[1000];
    cin>>t;
    while(t--)
    {
        memset(val,0,sizeof(val));
        cin>>n;
        for(int j=0; j<n; j++)
        {
            cin>>a[j];
            temp=a[j]+j;
            val[temp]=1;  ///让)==1 (==0
            /*for(int i=0;i<n*2;i++) ///输出1的地方
            cout<<val[i]<<' ';
            cout<<endl;*/
            ///cout<<val[temp]<<endl;   ==1    从后往前数)的个数
            for(int i=temp-1,sum=1,falg=0; i>=0; i--) ///  val[i]==) flag标记(是否与)匹配的
            {
                if(falg==0&&val[i]==0)   ///eg:)
                {
                    w[j]=sum;
                    break;
                }
                else if(val[i]==0)   ///eg:((())
                {
                    falg--;
                }
                else if(val[i]==1) ///eg:)))
                {
                    sum++;
                    falg++;
                }
            }
        }
        for(int i=0; i<n; i++)
        {
            cout<<w[i]<<' ';
        }
      cout<<endl;
    }
    return 0;
}

注释:

题意:P:从左到右  遇见第i个完整括号开始  (的个数     q:从左到右遇见第一个)时   与该)匹配的括号内 )的个数    (包含该))

1: 因为不用输出括号  所以将(标记为0  )标记为1    

2:对于q 要计算一个大括号内的全部)   所以要从后向前遍历

posted on 2014-07-18 10:29  点点滴滴”  阅读(122)  评论(0编辑  收藏  举报