找规律 ZOJ3498 Javabeans

Javabeans are delicious. Javaman likes to eat javabeans very much.

Javaman has n boxes of javabeans. There are exactly i javabeans in the i-th box (i = 1, 2, 3,...n). Everyday Javaman chooses an integer x. He also chooses several boxes where the numbers of javabeans are all at least x. Then he eats x javabeans in each box he has just chosen. Javaman wants to eat all the javabeans up as soon as possible. So how many days it costs for him to eat all the javabeans?

Input

There are multiple test cases. The first line of input is an integer T ≈ 100 indicating the number of test cases.

Each test case is a line of a positive integer 0 < n < 231.

Output

For each test case output the result in a single line.

Sample Input

4
1
2
3
4

Sample Output

1
2
2
3





一个比较简单的找规律题
有n个盒子。第i个盒子有i个javabean,每天可以选择一个x,然后把盒子里有大于等于x个javabeans里吃掉x个,问最少需要几天才能吃完。
n个盒子。。每天吃(n+1)/2个。。。

AC代码如下
#include <math.h>
#include<stdio.h>
int main()
{
    int ans,n,t;
    scanf("%d",&t);
    while(t--)
    {
        ans=0;
        scanf("%d",&n);
        while(n)
        {
            ans++;
            n=n/2;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 



posted on 2016-01-24 09:48  猪是的念来过倒  阅读(427)  评论(0编辑  收藏  举报