Uva - 1586 - Molar mass

An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. Themolar mass of an organic compound is the mass of one mole of the organic compound. The molar mass of an organic compound can be computed from the standard atomic weights of the elements.

\epsfbox{p3900.eps}

When an organic compound is given as a molecular formula, Dr. CHON wants to find its molar mass. A molecular formula, such as C3 H4 O3 , identifies each constituent element by its chemical symbol and indicates the number of atoms of each element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular element, this quantity is indicated using a subscript after the chemical symbol.

In this problem, we assume that the molecular formula is represented by only four elements, `C' (Carbon), `H' (Hydrogen), `O' (Oxygen), and `N' (Nitrogen) without parentheses.

The following table shows that the standard atomic weights for `C', `H', `O', and `N'.

Atomic Name Carbon Hydrogen Oxygen Nitrogen
Standard Atomic Weight 12.01 g/mol 1.008 g/mol 16.00 g/mol 14.01 g/mol


For example, the molar mass of a molecular formula C6 H5 OH is 94.108 g/mol which is computed by 6 × (12.01 g/mol) + 6 × (1.008 g/mol) + 1 × (16.00 g/mol).

Given a molecular formula, write a program to compute the molar mass of the formula.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases Tis given in the first line of the input. Each test case is given in a single line, which contains a molecular formula as a string. The chemical symbol is given by a capital letter and the length of the string is greater than 0 and less than 80. The quantity number n which is represented after the chemical symbol would be omitted when the number is 1 (2$ \le$n$ \le$99) .

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line should contain the molar mass of the given molecular formula.

Sample Input 

4 
C 
C6H5OH 
NH2CH2COOH 
C12H22O11

Sample Output 

12.010 
94.108 
75.070 
342.296
AC代码:

#include <stdio.h>
#include <ctype.h>
#include <string.h>
#define MAXN 100

// 判断字符ch是哪一个元素符号
double mass(char ch) {
	switch (ch)
	{
	case 'C':
		return 12.01;
	case 'H':
		return 1.008;
	case 'O':
		return 16.00;
	case 'N':
		return 14.01;
	}
}

int main()
{
	int T;
	char s[MAXN];
	scanf("%d", &T);
	while (T--) {
		scanf("%s", s);
		int n = strlen(s);
		double molarMass = 0.0;
		int i = 0;
		while (i < n) {
			// 分三种情况处理
			if (isalpha(s[i + 1]) || i == n - 1) {
				molarMass += mass(s[i]);
				i++;
			}
			else if (isdigit(s[i + 1]) && isalpha(s[i + 2])) {
				molarMass += mass(s[i]) * (s[i + 1] - '0');
				i += 2;
			}
			else {
				molarMass += mass(s[i]) * ((s[i + 1] - '0') * 10 + (s[i + 2] - '0'));
				i += 3;
			}
		}
		printf("%.3lf\n", molarMass); // 注意只需要保留小数点后3位
	}
	return 0;
}



posted @ 2015-06-08 23:55  Say舞步  阅读(178)  评论(0编辑  收藏  举报