Uva - 455 - Periodic Strings

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2
AC 代码:

暴力穷举周期数即可

<pre name="code" class="cpp">#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cstdio>

int main()
{
	int n;
	char str[104];
	while (~scanf("%d", &n)) {
		while (n--) {
			scanf("%s", str);
			int len = strlen(str);
			for (int k, i = 1; i <= len; ++i)
				if (len % i == 0) { // 判断i是否能作为周期数
					for (k = i; k < len; ++k) // 判断后面的是否满足周期性
						if (str[k] != str[k % i])
							break;
					if (k == len) {
						printf("%d\n", i);
						break;
					}
				}
			if (n) printf("\n");
		}
	}
	return 0;
}



posted @ 2015-06-09 01:05  Say舞步  阅读(130)  评论(0编辑  收藏  举报