angry_birds_again_and_again(2014年山东省第五届ACM大学生程序设计竞赛A题)

http://acm.sdut.edu.cn/sdutoj/problem.php?action=showproblem&problemid=2877

题目描述

The problems called "Angry Birds" and "Angry Birds Again and Again" has been solved by many teams in the series of contest in 2011 Multi-University Training Contest.
 
This time we focus on the yellow bird called Chuck. Chuck can pick up speed and distance when tapped.
 
You can assume that before tapped, Chuck flies along the parabola. When tapped, it changes to fly along the tangent line. The Chuck starts at the coordinates (0, 0). Now you are given the coordinates of the pig (Px, 0), the x-coordinate of the tapping position (Tx) and the initial flying angle of Chuck (α).

∠AOx = α
Please calculate the area surrounded by Chuck’s path and the ground.(The area surrounded by the solid line O-Tapping position-Pig-O)

输入

The first line contains only one integer T (T is about 1000) indicates the number of test cases. For each case there are two integers, px tx, and a float number α.(0 < Tx ≤ Px ≤ 1000, 0 < α <  ) .

输出

One line for each case specifying the distance rounded to three digits.

示例输入

1
2 1 1.0

示例输出

0.692

提示

数学知识学得很不扎实,很大程度程度上是在应付考试,导致不会灵活运用,在高中这种题手到擒来,但现在感觉做的有点费事。

来源

2014年山东省第五届ACM大学生程序设计竞赛
 
复制代码
#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;

int main()
{
    int T;
    double px,tx,t,ty,sum,a;
    cin>>T;
    while(T--)
    {
        cin>>px>>tx>>a;
        t=(tan(a)*px)/(tx*tx-2.0*tx*px);
        ty=t*tx*tx+tx*tan(a);
        sum=(0.5*(px-tx)*ty)+(1/3.0*t*tx*tx*tx+0.5*tan(a)*tx*tx);
        printf("%.3lf\n",sum);
    }
    return 0;
}
复制代码

 

简单数学题,大神的思路

复制代码
//题意:求由实线O-Tappingposition-Pig-O所围成图形的面积 s.

#include<stdio.h>
#include<math.h>
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int t,p;
        double a,t1,t2;
        scanf("%d%d%lf",&p,&t,&a);
        t1=p*t*(3*p-2*t);
        t2=6*(2*p-t);
        printf("%.3lf\n",t1/t2*tan(a));
    }
    return 0;
}
/*由题意可设抛物线方程为f(x)=a*x^2+b*x ,Tap点的纵坐标为 y,
由O-Tappingposition-Tx-O所围成图形的面积为 s1, 
由Tx-Tappingposition-pig-Tx所围成图形的面积为s2.
f'(x)=2*a*x+b
s=s1+s2  ...... (1)
s2=1/2*(px-tx)*y  ...... (2)
s1=1/3*a*tx^3+1/2*b*tx^2  ...... (3)
f'(0)=tan(a) => b=tan(a)  ...... (4)
f(tx)=y => a*tx^2+b*tx=y  ...... (5)
f'(tx)=-y/(px-tx) => 2*a*tx+b=-y/(px-tx)  ...... (6)
联立(1)(2)(3)(4)(5)(6)解得:s=[px*tx*(3*px-2*tx)]/[6*(2*px-tx)]*tan(a)*/
复制代码

 

posted @   人艰不拆_zmc  阅读(312)  评论(0编辑  收藏  举报
编辑推荐:
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· 阿里巴巴 QwQ-32B真的超越了 DeepSeek R-1吗?
· 【译】Visual Studio 中新的强大生产力特性
· 张高兴的大模型开发实战:(一)使用 Selenium 进行网页爬虫
· 【设计模式】告别冗长if-else语句:使用策略模式优化代码结构
点击右上角即可分享
微信分享提示