POJ1426:Find The Multiple(算是bfs水题吧,投机取巧过的)

http://poj.org/problem?id=1426

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

大致题意:

给出一个整数n,(1 <= n <= 200)。求出任意一个它的倍数m,要求m必须只由十进制的'0'或'1'组成。

没看见是Special Judge
题解:
我感觉这题能够是投机取巧,输出结果根本就没有100位,之前以为是大数,一直没敢做,谁知是一个超级大坑题。
还有给的测试数据给的那么大,害我一看测试数据就不敢做了。还有为什么我用STL中的queue用C++交超时,而用G++就A了
,而自己写的结构体用C++交就过了。
主要思想:
和二叉树差不多,1->10,11;10->100,101,11->110,111.....
就是q.push(t*10);q.push(t*10+1);
复制代码
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;
int n;
struct node
{
    long long int x;
} q[10000001];
struct node t,f;
void bfs()
{
    int s=0;
    int e=0;
    t.x=1;
    q[e++]=t;
    while(s<e)
    {
        t=q[s++];
        if(t.x%n==0)
        {
            printf("%lld\n",t.x);
            break;
        }
        f.x=t.x*10;
        q[e++]=f;
        f.x=t.x*10+1;
        q[e++]=f;
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        bfs();
    }
    return 0;
}
复制代码

 G++;

复制代码
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <queue>
using namespace std;
int n;
long long t;
void bfs()
{
    queue<long long >q;
    q.push(1);
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        if(t%n==0)
        {
            printf("%lld\n",t);
            break;
        }
        q.push(t*10);
        q.push(t*10+1);
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        bfs();
    }
    return 0;
}
View Code
复制代码

 

posted @   人艰不拆_zmc  阅读(388)  评论(0编辑  收藏  举报
编辑推荐:
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· 阿里巴巴 QwQ-32B真的超越了 DeepSeek R-1吗?
· 【译】Visual Studio 中新的强大生产力特性
· 张高兴的大模型开发实战:(一)使用 Selenium 进行网页爬虫
· 【设计模式】告别冗长if-else语句:使用策略模式优化代码结构
点击右上角即可分享
微信分享提示