POJ:Dungeon Master(三维bfs模板题)

Dungeon Master
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 16748   Accepted: 6522

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!
题解:
就是很裸的模板题,细心就好。其中'S'是起点,‘E’是终点,‘#’不能走。
复制代码
#include <iostream>
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
char map[51][51][51];
int fx[6]= {1,-1,0,0,0,0};
int fy[6]= {0,0,1,-1,0,0};
int fz[6]= {0,0,0,0,1,-1};
struct node
{
    int ans;
    int x,y,z;
};
struct node t,f;
int v[51][51][51];
int n,m,k;
void bfs(int xx,int yy,int zz)
{
    memset(v,0,sizeof(v));
    queue<node>q;
    t.x=xx;
    t.y=yy;
    t.z=zz;
    t.ans=0;
    q.push(t);
    v[t.x][t.y][t.z]=1;
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        if(map[t.x][t.y][t.z]=='E')
        {
            printf("Escaped in %d minute(s).\n",t.ans);
            return ;
        }
        for(int i=0; i<6; i++)
        {
            f.x=t.x+fx[i];
            f.y=t.y+fy[i];
            f.z=t.z+fz[i];
            if(f.x>=0&&f.x<n&&f.y>=0&&f.y<m&&f.z>=0&&f.z<k&&v[f.x][f.y][f.z]==0&&map[f.x][f.y][f.z]!='#')
            {
                v[f.x][f.y][f.z]=1;
                f.ans=t.ans+1;
                q.push(f);
            }
        }
    }
    printf("Trapped!\n");
    return ;
}
int main()
{
    int xx,yy,zz;
    while(scanf("%d%d%d",&n,&m,&k)!=EOF)
    {
        if(n==0&&m==0&&k==0) break;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                scanf("%*c%s",map[i][j]);
            }
        }
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                for(int z1=0; z1<k; z1++)
                {
                    if(map[i][j][z1]=='S')
                    {
                        xx=i;
                        yy=j;
                        zz=z1;
                        break;
                    }
                }
            }
        }
        bfs(xx,yy,zz);
    }
    return 0;
}
复制代码

 

 
posted @   人艰不拆_zmc  阅读(241)  评论(0编辑  收藏  举报
编辑推荐:
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· 阿里巴巴 QwQ-32B真的超越了 DeepSeek R-1吗?
· 【译】Visual Studio 中新的强大生产力特性
· 张高兴的大模型开发实战:(一)使用 Selenium 进行网页爬虫
· 【设计模式】告别冗长if-else语句:使用策略模式优化代码结构
点击右上角即可分享
微信分享提示