HDU1171:Big Event in HDU

http://acm.hdu.edu.cn/showproblem.php?pid=1171

复制代码
Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
2
10 1
20 1
3
10 1 
20 2
30 1
-1
 

Sample Output
20 10
40 40
 
复制代码

 

题意:给出每个物体的价值和物体的数量,如何分使得A,B所得价值最接近并且A的价值不能小于B

思路:将总和平分后,就是一道多重背包题了

复制代码
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define N 1000001
using namespace std;
int dp[101000],w1[1051],num1[1051],V,V1,n;
void wpack(int w)
{
    for(int i=w; i<=V; i++)
    {
        if(dp[i-w]+w>dp[i])
            dp[i]=dp[i-w]+w;
    }
}
void pack01(int w)
{
    for(int i=V; i>=w; i--)
    {
        if(dp[i-w]+w>dp[i])
            dp[i]=dp[i-w]+w;
    }
}
void MUl(int w,int num)
{
    if(w*num>=V)
    {
        wpack(w);
        return ;
    }
    int k=1;
    while(k<num)
    {
        pack01(w*k);
        num-=k;
        k=k*2;
    }
    pack01(num*w);
    return ;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n<=0) break;
        V=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&w1[i],&num1[i]);
            V=V+w1[i]*num1[i];
        }
        V1=V;
        V=V/2;
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            MUl(w1[i],num1[i]);
        }
        printf("%d %d\n",V1-dp[V],dp[V]);
    }
    return 0;
}
复制代码

 

posted @   人艰不拆_zmc  阅读(228)  评论(0编辑  收藏  举报
编辑推荐:
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· 阿里巴巴 QwQ-32B真的超越了 DeepSeek R-1吗?
· 【译】Visual Studio 中新的强大生产力特性
· 张高兴的大模型开发实战:(一)使用 Selenium 进行网页爬虫
· 【设计模式】告别冗长if-else语句:使用策略模式优化代码结构
点击右上角即可分享
微信分享提示