Saving Princess claire_(hdu 4308 bfs模板题)

http://acm.hdu.edu.cn/showproblem.php?pid=4308 

                   Saving Princess claire_

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2305    Accepted Submission(s): 822


Problem Description
Princess claire_ was jailed in a maze by Grand Demon Monster(GDM) teoy.
Out of anger, little Prince ykwd decides to break into the maze to rescue his lovely Princess.
The maze can be described as a matrix of r rows and c columns, with grids, such as 'Y', 'C', '*', '#' and 'P', in it. Every grid is connected with its up, down, left and right grids.
There is only one 'Y' which means the initial position when Prince ykwd breaks into the maze.
There is only one 'C' which means the position where Princess claire_ is jailed.
There may be many '*'s in the maze, representing the corresponding grid can be passed through with a cost of certain amount of money, as GDM teoy has set a toll station.
The grid represented by '#' means that you can not pass it.
It is said that as GDM teoy likes to pee and shit everywhere, this grid is unfortunately damaged by his ugly behavior.
'P' means it is a transmission port and there may be some in the maze. These ports( if exist) are connected with each other and Prince ykwd can jump from one of them to another.

They say that there used to be some toll stations, but they exploded(surely they didn't exist any more) because of GDM teoy's savage act(pee and shit!), thus some wormholes turned into existence and you know the following things. Remember, Prince ykwd has his mysterious power that he can choose his way among the wormholes, even he can choose to ignore the wormholes.
Although Prince ykwd deeply loves Princess claire_, he is so mean that he doesn't want to spend too much of his money in the maze. Then he turns up to you, the Great Worker who loves moving bricks, for help and he hopes you can calculate the minimum money he needs to take his princess back.
 

 

Input
Multiple cases.(No more than fifty.)
The 1st line contains 3 integers, r, c and cost. 'r', 'c' and 'cost' is as described above.(0 < r * c <= 5000 and money is in the range of (0, 10000] )
Then an r * c character matrix with 'P' no more than 10% of the number of all grids and we promise there will be no toll stations where the prince and princess exist.
 

 

Output
One line with an integer, representing the minimum cost. If Prince ykwd cannot rescue his princess whatever he does, then output "Damn teoy!".(See the sample for details.)
 

 

Sample Input
1 3 3
Y*C
1 3 2
Y#C
1 5 2
YP#PC
 
Sample Output
3
Damn teoy!
0
 题目唯一需要注意的是,P是传送带,可进入所有传送带。
复制代码
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;
int n,m,V;
char map[1001][1001];
int v[1001][1001];
struct node
{
    int x,y,ans;
}q[100001];
int jx[]={1,-1,0,0};
int jy[]={0,0,1,-1};
void bfs(int xx,int yy)
{
    int e=0;
    int s=0;
    memset(v,0,sizeof(v));
    struct node t,f;
    t.x=xx;
    t.y=yy;
    t.ans=0;
    v[t.x][t.y]=1;
    q[e++]=t;
    while(s<e)
    {
        t=q[s++];
        if(map[t.x][t.y]=='C')
        {
            printf("%d\n",t.ans);
            return ;
        }
        for(int i=0;i<4;i++)
        {
            f.x=t.x+jx[i];
            f.y=t.y+jy[i];
            if(f.x>=0&&f.x<n&&f.y>=0&&f.y<m&&map[f.x][f.y]!='#'&&v[f.x][f.y]==0)
            {
                if(map[f.x][f.y]=='*')
                {
                    f.ans=t.ans+V;
                    q[e++]=f;
                    v[f.x][f.y]=1;
                }
                else if(map[f.x][f.y]=='C')
                {
                    f.ans=t.ans;
                    q[e++]=f;
                    v[f.x][f.y]=1;
                }
                else if(map[f.x][f.y]=='P')
                {
                    for(int j=0;j<n;j++)
                    {
                        for(int k=0;k<m;k++)
                        {
                            if(map[j][k]=='P')
                            {
                                f.ans=t.ans;
                                f.x=j;
                                f.y=k;
                                q[e++]=f;
                                v[f.x][f.y]=1;
                            }
                        }
                    }
                }
            }
        }
    }
    printf("Damn teoy!\n");
    return ;
}
int main()
{
    int xx,yy;
    while(scanf("%d%d%d",&n,&m,&V)!=EOF)
    {
        for(int i=0;i<n;i++)
        scanf("%*c%s",map[i]);
        int j;
        for(int i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(map[i][j]=='Y')
                {
                    xx=i;
                    yy=j;
                    break;
                }
            }
            if(j!=m) break;
        }
        bfs(xx,yy);
    }
    return 0;
}
View Code
复制代码

 

 
posted @   人艰不拆_zmc  阅读(345)  评论(0编辑  收藏  举报
编辑推荐:
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· 阿里巴巴 QwQ-32B真的超越了 DeepSeek R-1吗?
· 【译】Visual Studio 中新的强大生产力特性
· 张高兴的大模型开发实战:(一)使用 Selenium 进行网页爬虫
· 【设计模式】告别冗长if-else语句:使用策略模式优化代码结构
点击右上角即可分享
微信分享提示