POJ1611:The Suspects(模板题)

http://poj.org/problem?id=1611

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

0号患了病毒,只要和0号一组的人同样会患病毒。。。。

复制代码
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int bin[30010];
int q[30010];
int n,m;
int cmp(const void *a,const void *b)
{
    return *(int *)a-*(int *)b;
}
int findx(int x)
{
    int r,j,k;
    r=x;
    while(bin[r]!=r)
        r=bin[r];
    k=x;
    while(k!=r)
    {
        j=bin[k];
        bin[k]=r;
        k=j;

    }
    return r;
}
void merge(int x,int y)
{
    int fx,fy;
    fx=findx(x);
    fy=findx(y);
    if(fx!=fy)
    {
        bin[fx]=fy;
    }
}

int main()
{
    int n,x,t,i,j;
    while(scanf("%d%d",&n,&x)!=EOF)
    {
        if(n==0&&x==0) break;
        for(i=0; i<n; i++)
            bin[i]=i;
        while(x--)
        {
            scanf("%d",&t);
            memset(q,0,sizeof(q));
            for(j=0; j<t; j++)
                scanf("%d",&q[j]);
            qsort(q,t,sizeof(q[0]),cmp);
            for(j=1; j<t; j++)
            {
                merge(q[j],q[j-1]);
            }

        }
        /*for(i=0;i<n;i++)
        printf("...%d",bin[i]);*/
        int l=1;
        for(i=1; i<n; i++)
        {
            if(findx(i)==findx(0))
                l++;

        }
        printf("%d\n",l);

    }
    return 0;
}
View Code
复制代码

 

 

posted @   人艰不拆_zmc  阅读(225)  评论(0编辑  收藏  举报
编辑推荐:
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· 阿里巴巴 QwQ-32B真的超越了 DeepSeek R-1吗?
· 【译】Visual Studio 中新的强大生产力特性
· 张高兴的大模型开发实战:(一)使用 Selenium 进行网页爬虫
· 【设计模式】告别冗长if-else语句:使用策略模式优化代码结构
点击右上角即可分享
微信分享提示