poj3278 Catch That Cow(简单的一维bfs)

http://poj.org/problem?id=3278

                                                                                 Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 47010   Accepted: 14766

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

数组必须开大点

复制代码
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

using namespace std;
struct node
{
    int x,ans;
} q[1000005];
int jx[]= {-1,1};
int n,k;
int map[1000005],v[1000005];
void bfs()
{
    struct node t,f;
    int e=0,s=0;
    t.x=n;
    v[t.x]=1;
    t.ans=0;
    q[e++]=t;
    while(s<e)
    {
        t=q[s++];
        if(t.x==k)
        {
            printf("%d\n",t.ans);
            break;
        }
        for(int i=0; i<3; i++)
        {
            if(i==2)
                f.x=t.x*2;
            else f.x=t.x+jx[i];
            if(!v[f.x]&&f.x>=0&&f.x<=100000)
            {
                f.ans=t.ans+1;
                q[e++]=f;
                v[f.x]=1;
            }
        }
    }
}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(map,0,sizeof(map));
        memset(v,0,sizeof(v));
        bfs();
    }
    return 0;
}
复制代码

 

posted @   人艰不拆_zmc  阅读(397)  评论(0编辑  收藏  举报
编辑推荐:
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· 阿里巴巴 QwQ-32B真的超越了 DeepSeek R-1吗?
· 【译】Visual Studio 中新的强大生产力特性
· 张高兴的大模型开发实战:(一)使用 Selenium 进行网页爬虫
· 【设计模式】告别冗长if-else语句:使用策略模式优化代码结构
点击右上角即可分享
微信分享提示