Hdu 1520 Anniversary party

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11160    Accepted Submission(s): 4615

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

 

 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

 

 

Output

Output should contain the maximal sum of guests' ratings.

 

 

Sample Input

7

1

1

1

1

1

1

1

1 3

2 3

6 4

7 4

4 5

3 5

0 0

 

 

Sample Output

5

#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <iostream>

using namespace std;

#define N 6005
int dp[N][2], val[N], visit[N];
int in[N];
struct node {
	int v;
	int next;
}pe[N<<1];

int e, head[N];
void init () {
	memset  (head, -1, sizeof (head));
	e = 0;
}
void addedge (int u, int v) {
	pe[e].v = v;
	pe[e].next = head[u];
	head[u] = e ++;
}
int dfs (int u) {
	visit[u] = 1;
	dp[u][0] = 0;
	dp[u][1] = val[u];
	for (int i = head[u]; i != -1; i = pe[i].next) {
		int v = pe[i].v;
		dfs(v);
		dp[u][0] += max(dp[v][0],  dp[v][1]);
		dp[u][1] += dp[v][0];
	}
	return max(dp[u][0], dp[u][1]);
}

int main() {
	int n, v, u;
	while (scanf ("%d", &n) != EOF) {
		init();
		for (int i = 1; i <= n; ++i) {
			in[i] = 0;
			visit[i] = 0;
			scanf ("%d", &val[i]);
		}
		while (scanf ("%d%d", &v, &u) && v + u != 0) {
			addedge (u, v);
			in[v]++;
		}
		int ans = 0;
		for (int i = 1; i <= n; ++i) {
			if(!in[i])
				ans += dfs(i);
		}
		printf("%d\n", ans);
	}
	return 0;
}

  

posted @ 2017-06-22 09:24  寂地沉  阅读(120)  评论(0编辑  收藏  举报