Hdu 1054 Strategic Game

Strategic Game

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8191    Accepted Submission(s): 3919

Problem Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:



the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

 

 

Sample Input

4

0:(1) 1

1:(2) 2 3

2:(0)

3:(0)

5

3:(3) 1 4 2

1:(1) 0

2:(0)

0:(0)

4:(0)

 

 

Sample Output

1

2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
#include<cstdio> 
#include<cstdlib> 
#include<cstring> 
#include<cmath> 
#include <vector> 
#include<algorithm>  using namespace std; 
   
const int maxn=1510; 
int n; 
int pre[maxn];//保存各点的匹配点  int vis[maxn]; 
vector<int> e[maxn]; 
int find(int u)//判断是否存在增广路,存在返回1  { 
    int i,v; 
    for(i=0;i<e[u].size();i++) 
    
        v=e[u][i]; 
        if(vis[v])continue
        vis[v]=1; 
        if(pre[v]==-1||find(pre[v]))//找到未盖点,或者是增广路。          { 
            pre[v]=u;//匹配边和非匹配边交换              return 1; 
        
    
    return 0; 
   
int main() 
    while(scanf("%d",&n)!=EOF) 
    
        int i,j,k,a,b,c,m; 
        memset(pre,-1,sizeof(pre)); 
        for(i=0;i<n;i++)e[i].clear(); 
        for(i=0;i<n;i++) 
        
            scanf("%d:(%d)",&a,&m); 
            for(j=0;j<m;j++) 
            
                scanf("%d",&b); 
                e[a].push_back(b); 
                e[b].push_back(a); 
            
        
        int ans=0; 
        for(i=0;i<n;i++) 
        
            memset(vis,0,sizeof(vis)); 
            ans+=find(i); 
        
        printf("%d\n",ans/2); 
    
    return 0; 
}

  

posted @   寂地沉  阅读(116)  评论(0编辑  收藏  举报
编辑推荐:
· 理解Rust引用及其生命周期标识(下)
· 从二进制到误差:逐行拆解C语言浮点运算中的4008175468544之谜
· .NET制作智能桌面机器人:结合BotSharp智能体框架开发语音交互
· 软件产品开发中常见的10个问题及处理方法
· .NET 原生驾驭 AI 新基建实战系列:向量数据库的应用与畅想
阅读排行:
· C# 13 中的新增功能实操
· Ollama本地部署大模型总结
· 2025成都.NET开发者Connect圆满结束
· langchain0.3教程:从0到1打造一个智能聊天机器人
· 用一种新的分类方法梳理设计模式的脉络
点击右上角即可分享
微信分享提示