Hdu 1021 Fibonacci Again

Fibonacci Again
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61094    Accepted Submission(s): 28545

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
0
1
2
3
4
5
 

Sample Output
no
no
yes
no
no
no

#include<stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0||n==1)
        {
            printf("no\n");
            continue;
        }
        int a=1,b=2,c,i;
        for(i=2;i<=n;i++)
        {
            if(a+b>=3)
                c=a+b-3;
            else
                c=a+b;
            a=b;
            b=c;
        }
        if(c==0)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}

  

posted @ 2017-06-21 09:09  寂地沉  阅读(150)  评论(0编辑  收藏  举报