Hdu 1020 Encoding

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46637    Accepted Submission(s): 20705

Problem Description

Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

 

 

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

 

 

Output

For each test case, output the encoded string in a line.

 

 

Sample Input

2

ABC

ABBCCC

 

 

Sample Output

ABC

A2B3C

#include<stdio.h>
#include<string.h>int main()
{
    int N,i;
    char str[10010];
    scanf("%d",&N);
    while(N--)
    {
        int sum=1,m=0;
        memset(str,'\0',sizeof(str));
        scanf("%s",str);
        for(i=1;i<=strlen(str);i++)
        {
            if(m==0&&str[i]!=str[i-1])
                printf("%c",str[i-1]);
            else if(m==1&&str[i]!=str[i-1])
                m=0,printf("%d%c",sum,str[i-1]),sum=1;
            else
            {
                sum++;
                m=1;
                continue;
            }
        }
        printf("\n");
    }
    return 0;
}

  

posted @ 2017-06-21 09:07  寂地沉  阅读(165)  评论(0编辑  收藏  举报