Hdu 1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 246702    Accepted Submission(s): 58259

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

 

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

 

Sample Input

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

 

 

Sample Output

Case 1:

14 1 4

 

Case 2:

7 1 6

#include<stdio.h>  
int main() 
{ 
    int T; 
    int k; 
    scanf("%d", &T); 

    for (k = 1; k <= T; k++) 
    { 
        int N; 
        int a; 
        int i; 
        int start, end, pos; 
        int temp, result; 

        scanf("%d", &N); 
        scanf("%d", &a); 

        start = end = pos = 0; 
        temp = result = a; 

        for (i = 1; i < N; i++) 
        { 
            scanf("%d", &a); 
            if (temp + a < a) 
            { 
                temp = a; 
                pos = i; 
            } 
            else 
            { 
                temp += a; 
            } 
            if (temp > result) 
            { 
                result = temp; 
                start = pos; 
                end = i; 
            } 
        } 
        printf("Case %d:\n", k); 
        printf("%d %d %d\n", result, start+1, end+1); 
        if (k != T) 
            printf("\n"); 
    } 

    return 0; 
} 

  

posted @ 2017-06-21 09:03  寂地沉  阅读(197)  评论(0编辑  收藏  举报