nyoj 43 24 Point game

24 Point game

时间限制:3000 ms  |  内存限制:65535 KB

难度:5

描述

There is a game which is called 24 Point game.

In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn't have any other operator except plus,minus,multiply,divide and the brackets. 

e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested. 

Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。

输入

The input has multicases and each case contains one line
The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases.
Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be.
Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100

输出

For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.

样例输入

2

4 24 3 3 8 8

3 24 8 3 3

样例输出

Yes

No

/*
题意:输入有t组 每组的n,m和n个数,问这n个数是否经过运算后是否和m相等,n个数的位置可调换
搜索大体思路:把n个数经过一次运算后话为n-1向下搜索
*/
#include<stdio.h>
const double E=1e-9;
int n;
double v,num[7];
double fac(double aa)
{
    if(aa>v)
        return aa-v;
    else
        return v-aa;
}
int dfs(int t)
{
    if(t==n)//实数判断相等看精度
    {
        if(fac(num[n])<E)
            return 1;
    }
    double right,left;
    for(int i=t;i<n;i++)
        for(int j=i+1;j<=n;j++)
        {
            left=num[i];
            right=num[j];
            num[i]=num[t];//我们把num[i]和num[j]的值存到num[j]中num[i]就没有用了,当i和t不相等时把num[t]的值存到num[i],因为这个时候num[t]这个数没有使用。这样经过一次运算就减少了一个数
            num[j]=left+right;//加
            if(dfs(t+1))
                return 1;
            num[j]=left-right;//减
            if(dfs(t+1))
                return 1;
            num[j]=right-left;//减
            if(dfs(t+1))
                return 1;
            num[j]=right*left;//乘
            if(dfs(t+1))
                return 1;
            if(right)//除
            {
                num[j]=left/right;
                if(dfs(t+1))
                    return 1;
            }
            if(left)//除
            {
                num[j]=right/left;
                if(dfs(t+1))
                    return 1;
            }
            num[i]=left;//还原
            num[j]=right;
        }
        return 0;
}
int main()
{
    int i,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%lf",&n,&v);
        for(i=1;i<=n;i++)
            scanf("%lf",&num[i]);
        if(dfs(1))
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}    

  

posted @ 2017-06-20 10:22  寂地沉  阅读(158)  评论(0编辑  收藏  举报