1086 Tree Traversals Again

1086 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

思路:
  题中给出了先序和中序遍历序列,可以唯一确定一颗树,所以首先可以进行建立树,然后后序遍历即可。
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
#include<stack>
using namespace std;
vector<int> po;
struct Node
{
    int data;
    Node *lchild=nullptr;
    Node *rchild=nullptr;
};

void createTree(Node *&root,vector<int>preOrder,int pl,int pr,
                vector<int>inOrder,int il,int ir)
{
    if(root==nullptr)
    {
        root=new Node;
        root->data=preOrder[pl];
    }
    int index=0;
    while(inOrder[index]!=preOrder[pl]) index++; 
    int len=index-il;
    int rlen=ir-index;
    if(len>0)
        createTree(root->lchild,preOrder,pl+1,pr-rlen,inOrder,il,index-1);
    if(rlen>0)
        createTree(root->rchild,preOrder,pr-rlen+1,pr,inOrder,index+1,ir);
}
vector<int> print;
void postOrder(Node *root)
{
    if(!root)
        return;
    postOrder(root->lchild);
    postOrder(root->rchild);
    print.push_back(root->data);
}

int main()
{
    int n;
    cin>>n;
    vector<int>inOrder;
    vector<int>preOrder;
    stack<int> st;
    string str;
    int temp;
    for(int i=0;i<2*n;i++)
    {
        cin>>str;
        if(str=="Push")
        {
            cin>>temp;
            preOrder.push_back(temp);
            st.push(temp);
        }
        else
        {
            temp=st.top();
            st.pop();
            inOrder.push_back(temp);
        }
    }
    Node *root=nullptr;
    createTree(root,preOrder,0,preOrder.size()-1,inOrder,0,inOrder.size()-1);
    postOrder(root);
    cout<<print[0];
    for(int i=1;i<print.size();i++)
        cout<<" "<<print[i];
    return 0;
}

 

 

posted on 2019-01-24 13:50  ZhangのBlog  阅读(145)  评论(0编辑  收藏  举报