1054 The Dominant Color (20 分)map的使用

1054 The Dominant Color (20 分)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (800) and N (600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
using namespace std;

map<string,int>mp;

int main()
{
    int m,n;
    scanf("%d%d",&m,&n);

    int res=m*n;
    for(int i=0;i<res;i++)
    {
        char ch[1000];
        //cout<<ch<<endl;
        scanf("%s",ch);
        string temp=string(ch);
        if(mp.find(temp)!=mp.end())
            mp[temp]++;
        else
            mp[temp]=1;
    }
    int temp=res/2;
    for(auto it=mp.begin();it!=mp.end();it++)
    {
        if(it->second>temp)
        {
            cout<<it->first;
            return 0;
        }
    }
    return 0;
}

 

posted on 2019-01-22 22:16  ZhangのBlog  阅读(124)  评论(0编辑  收藏  举报