1014 Waiting in Line 队列

Suppose a bank has NNN windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with MMM customers. Hence when all the NNN lines are full, all the customers after (and including) the (NM+1)(NM+1)(NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • CustomeriCustomer_iCustomeri​​ will take TiT_iTi​​ minutes to have his/her transaction processed.
  • The first NNN customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1customer_1customer1​​ is served at window1window_1window1​​ while customer2customer_2customer2​​ is served at window2window_2window2​​. Customer3Customer_3Customer3​​ will wait in front of window1window_1window1​​ and customer4customer_4customer4​​ will wait in front of window2window_2window2​​. Customer5Customer_5Customer5​​ will wait behind the yellow line.

At 08:01, customer1customer_1customer1​​ is done and customer5customer_5customer5​​ enters the line in front of window1window_1window1​​ since that line seems shorter now. Customer2Customer_2Customer2​​ will leave at 08:02, customer4customer_4customer4​​ at 08:06, customer3customer_3customer3​​ at 08:07, and finally customer5customer_5customer5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: NNN (≤20\le 2020, number of windows), MMM (≤10\le 1010, the maximum capacity of each line inside the yellow line), KKK (≤1000\le 10001000, number of customers), and QQQ (≤1000\le 10001000, number of customer queries).

The next line contains KKK positive integers, which are the processing time of the KKK customers.

The last line contains QQQ positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to KKK.

Output Specification:

For each of the QQQ customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output08:0708:0608:10

17:00
Sorry

注意点:
  1、题目中说的是不能在17:00前被服务的客户输出“Sorry”,并不是只要某个人的时间超过了17:00就输出Sorry
 
  2、这个题明显是考察队列的使用。
#include<iostream>
#include<sstream>
#include<algorithm>
#include<map>
#include<cmath>
#include<cstdio>
#include<string.h>
#include<queue>
using namespace std;


int main()
{
    int n,m,k,q;
    cin>>n>>m>>k>>q;
    queue<int> qu[n];
    int cost1[k+1],cost[k+1];//由于一个数组要做减法所以定义了两个
    for(int i=1; i<k+1; i++)
    {
        cin>>cost1[i];
        cost[i]=cost1[i];
    }
    int query[q+1];
    for(int i=0; i<q; i++)
        cin>>query[i];
    int left=1;//此时在黄线外侧的人
    long long time=0;
    map<int,long long> mp;
    bool flag;
    bool flag2=true;
    int minCost=10000;
    do
    {
        flag=false;
        for(int i=0; i<n; i++)
        {

            if(qu[i].size()>0)
            {
                flag=true;
                int temp=qu[i].front();
                cost[temp]-=minCost;
                if(cost[temp]==0)
                {
                    qu[i].pop();
                    mp[temp]=time;
                }
            }
            if(qu[i].size()<m&&left<k+1)
            {
                flag=true;
                qu[i].push(left);
                left++;
            }
        }
        minCost=100000;
        for(int i=0;i<n;i++)
        {
            if(qu[i].size()>0)
            {
                int temp=qu[i].front();
                if(cost[temp]<minCost)
                    minCost=cost[temp];
            }
        }
        time+=minCost;
    //cout<<time<<endl;
    }while(flag);
    int hours=0,minute=0;
    for(int i=0;i<q;i++)
    {
        int temp=query[i];
        hours=8+mp[temp]/60;
        minute=mp[temp]%60;
        if(hours>=17&&minute-cost1[temp]>=0)
            cout<<"Sorry"<<endl;
        else
        {
            printf("%02d:%02d\n",hours,minute);
        }
    }
    return 0;
}

 

posted on 2019-01-02 21:33  ZhangのBlog  阅读(382)  评论(0编辑  收藏  举报