采药
Sample Input
70 3 71 100 69 1 1 2
Sample Output
3
#include <iostream>
using namespace std;
int dp[1001]={0};
int main()
{
int t,m;
cin>>t>>m;//t为总时间,m为总草药数目
for(int j=0;j<m;j++)
{
int tempt,tempv;//tempt为采该药所需时间,tempv为该药价值
cin>>tempt>>tempv;
for(int i=t;i>=tempt;i--)
if(dp[i]<dp[i-tempt]+tempv)
dp[i]=dp[i-tempt]+tempv;
}
cout<<dp[t]<<endl;
return 0;
}