Subsequence POJ - 3061
Published on 2018-10-25 11:55 in 分类: 6.4 尺取法 with zgxme
分类: 6.4 尺取法

Subsequence POJ - 3061

    Subsequence
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 22040   Accepted: 9404

    Description

    A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

    Input

    The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

    Output

    For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

    Sample Input

    2
    10 15
    5 1 3 5 10 7 4 9 2 8
    5 11
    1 2 3 4 5

    Sample Output

    2
    3

    Source

     
    题意:给定长度为n的数列整数,及整数S。求出总和不小于S的连续子序列的长度的最小值
    思路:尺取法 用queue进行维护就可以哒~
     
    acode
    复制代码
    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<sstream>
    #include<cstring>
    #include<string>
    #include<vector>
    #include<set>
    #include<stack>
    #include<queue>
    #include<map>
    #include<cmath>
    #include<algorithm>
    using namespace std;
    #define inf 0x3f3f3f3f
    #define ll long long
    #define MAX_N 1000005
    #define gcd(a,b) __gcd(a,b)
    #define mem(a,x) memset(a,x,sizeof(a))
    #define mid(a,b) a+b/2
    #define stol(a) atoi(a.c_str())//string to long
    int temp[MAX_N];
    int main(){
        //std::ios::sync_with_stdio(false);
        //std::cin.tie(0);
    //    #ifndef ONLINE_JUDGE
    //        freopen("D:\\in.txt","r",stdin);
    //        freopen("D:\\out.txt","w",stdout);
    //    #else
    //    #endif
        int T;
        scanf("%d",&T);
        int N,S;
        while(T--){
            scanf("%d%d",&N,&S);
            for(int i = 0; i < N; i++)
                scanf("%d",&temp[i]);
            int sum = 0;
            queue<int> que;
            int res = inf;
            for(int i = 0; i < N; i++){
                que.push(temp[i]);
                sum += temp[i];
                while(sum >= S){
                    res = min(res,(int)que.size());
                    sum -= que.front();
                    que.pop();
                }
            }
            if(res!=inf)
                printf("%d\n",res);
            else
                printf("0\n");
        }
        return 0;
    }
    复制代码
    posted @   zgxme  阅读(160)  评论(0编辑  收藏  举报
    编辑推荐:
    · AI与.NET技术实操系列(二):开始使用ML.NET
    · 记一次.NET内存居高不下排查解决与启示
    · 探究高空视频全景AR技术的实现原理
    · 理解Rust引用及其生命周期标识(上)
    · 浏览器原生「磁吸」效果!Anchor Positioning 锚点定位神器解析
    阅读排行:
    · DeepSeek 开源周回顾「GitHub 热点速览」
    · 物流快递公司核心技术能力-地址解析分单基础技术分享
    · .NET 10首个预览版发布:重大改进与新特性概览!
    · AI与.NET技术实操系列(二):开始使用ML.NET
    · 单线程的Redis速度为什么快?
    点击右上角即可分享
    微信分享提示