Jessica's Reading Problem POJ - 3320
Published on 2018-10-25 11:08 in 分类: 6.4 尺取法 with zgxme
分类: 6.4 尺取法

Jessica's Reading Problem POJ - 3320

    Jessica's Reading Problem
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 17562   Accepted: 6099

    Description

    Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

    A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

    Input

    The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

    Output

    Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

    Sample Input

    5
    1 8 8 8 1
    

    Sample Output

    2

    Source

     
    题意:有n页书涵盖所有知识点,求涵盖所有知识点的连续页总数的最小值
    思路:尺取法 用set、map、queue进行维护就好了哒~
    accode
    复制代码
    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<sstream>
    #include<cstring>
    #include<string>
    #include<vector>
    #include<set>
    #include<stack>
    #include<queue>
    #include<map>
    #include<cmath>
    #include<algorithm>
    using namespace std;
    #define inf 0x3f3f3f3f
    #define ll long long
    #define MAX_N 1000005
    #define gcd(a,b) __gcd(a,b)
    #define mem(a,x) memset(a,x,sizeof(a))
    #define mid(a,b) a+b/2
    #define stol(a) atoi(a.c_str())//string to long
    int temp[MAX_N];
    int main(){
        //std::ios::sync_with_stdio(false);
        //std::cin.tie(0);
    //    #ifndef ONLINE_JUDGE
    //        freopen("D:\\in.txt","r",stdin);
    //        freopen("D:\\out.txt","w",stdout);
    //    #else
    //    #endif
        int n;
        queue<int> que;
        set<int> iset;
        map<int,int> imap;
        scanf("%d",&n);
        for(int i = 0; i < n; i++){
            scanf("%d",&temp[i]);
            iset.insert(temp[i]);
        }
        int k = iset.size();
        iset.clear();
        int res = inf;
        for(int i = 0; i < n; ++i){
            iset.insert(temp[i]);
            que.push(temp[i]);
            imap[temp[i]]++;
            if(iset.size() == k){
    //            printf("%d\n",i);
                res = min(res,(int)que.size());
            }
            while(iset.size() == k){
                int a = que.front();
                imap[a]--;
                que.pop();
                if(imap[a]==0){
                    res = min(res,(int)que.size()+1);
                    iset.erase(a);
                }
    
            }
    
        }
        printf("%d\n",res);
        return 0;
    }
    复制代码

     

    posted @   zgxme  阅读(141)  评论(0编辑  收藏  举报
    编辑推荐:
    · AI与.NET技术实操系列(二):开始使用ML.NET
    · 记一次.NET内存居高不下排查解决与启示
    · 探究高空视频全景AR技术的实现原理
    · 理解Rust引用及其生命周期标识(上)
    · 浏览器原生「磁吸」效果!Anchor Positioning 锚点定位神器解析
    阅读排行:
    · DeepSeek 开源周回顾「GitHub 热点速览」
    · 物流快递公司核心技术能力-地址解析分单基础技术分享
    · .NET 10首个预览版发布:重大改进与新特性概览!
    · AI与.NET技术实操系列(二):开始使用ML.NET
    · 单线程的Redis速度为什么快?
    点击右上角即可分享
    微信分享提示