HDU2289——二分——Cup

The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height? 

The radius of the cup's top and bottom circle is known, the cup's height is also known.
 

Input

The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases. 
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water. 

Technical Specification 

1. T ≤ 20. 
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000. 
3. r ≤ R. 
4. r, R, H, V are separated by ONE whitespace. 
5. There is NO empty line between two neighboring cases. 

 

Output

For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
 

Sample Input

1 100 100 100 3141562
 

Sample Output

99.999024
/*
耐心点推个公式
精度!!!。。。
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

const double esp = 1e-9;
const double pi = acos(-1.0);
int T;
double r, R, H, V;
double check(double x)
{
    double rr = x/H*(R-r) + r;
   // printf("%f\n",rr);
    double V1 = pi/3*x*(rr*rr + r*r + rr*r);
    return V1;
}

int main()
{
    scanf("%d", &T);
    while(T--){
        scanf("%lf%lf%lf%lf", &r, &R, &H, &V);
      //  if(r == R) {
      //     printf("%.6f\n", V/(pi*r*r));
      //     continue;
      //
        double ll = 0, rr = 100, mid;
        while(rr - ll  > esp){
         mid = (ll + rr) / 2;
        double VV = check(mid);
        if(fabs(VV - V) <= esp)
            break;
        else if(VV > V)
            rr = mid - esp;
        else ll = mid + esp;
        }
     printf("%.6f\n", mid);
    }
    return 0;
}

  

 
posted @ 2015-08-01 15:12  Painting、时光  阅读(190)  评论(0编辑  收藏  举报