POJ3273——二分——Monthly Expense

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
/*
题意:给你n个数据让你分成m个块,使得这m个块的sum里面的最大的最小
二分 l应该要是a[i]的最大值, WA了一发。。注意1e4 * 1e5 = 1e9 不超int
*/
#include <cstdio> 
#include <cstring>
#include <algorithm>
using namespace std;

const int MAX = 1e6 + 10;
int n, m;
int a[MAX];

bool check(int x)
{
    int sum = 0, b = 0;
    int cout = 1;
    for(int i = 1; i <= n ; i++){
        if(sum + a[i]> x){
           cout++;
           sum = a[i];
        }
        else sum += a[i];
    }
    if(cout > m) return false;
    return true;
}

int main()
{
    while(~scanf("%d%d", &n, &m)){
        int l = 0, r = 1e9 + 100;
        for(int i = 1; i <= n ; i++){
            scanf("%d", &a[i]);
            l = max(l, a[i]);
        }
        int ans = 0;
        while(l <= r){
            int mid = (l + r) >> 1;
            if(check(mid)){
                ans = mid;
                r = mid - 1;
            }
            else l = mid + 1;
        }
        printf("%d\n", ans);
    }
    return 0;
}

  

posted @ 2015-07-25 16:02  Painting、时光  阅读(135)  评论(0编辑  收藏  举报