BestCoder Round #40 1001——精度——Tom and paper

Problem Description

There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.

Input

In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper. T10,n109

Output

For each case, output a integer, indicates the answer.

Sample Input
3
2
7
12
Sample Output
6
16
14

 大意:给你一个n表示一个纸片的面积,长和宽都是整数,问你最小的纸片的周长

orz对于精度水题好讨厌的感觉,,

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
    int n;
    int T;
    scanf("%d",&T);
    while(T--){
    scanf("%d",&n);
        int ans = 2*(n+1);
        for(int i = 1; i*i <=n;i++){
            if(n % i == 0)
            ans = min(ans,2*(i + n/i));
        }
        printf("%d\n",ans);
    }
    return 0;
} 

  

posted @ 2015-05-09 21:43  Painting、时光  阅读(168)  评论(0编辑  收藏  举报