ZOJ14省赛3872——DP——Beauty of Array

140 - The 12th Zhejiang Provincial Collegiate Programming Contest - D
Beauty of Array

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38
大意:给你一组数,让你输出这组数中所有集合的和(如果集合中有两个或两个以上的数,那么只算一个)
dp指包括自己的集合总数
sum指结果
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[100001];
int main()
{
    int n,m,T;
    scanf("%d",&T);
    while(T--){
        long long sum,dp;
        scanf("%d",&n);
        sum = dp = 0;
        memset(a,0,sizeof(a));
        for(int i = 1; i <= n ; i++){
            scanf("%d",&m);
            dp = (i - a[m])*m + dp;
            sum += dp;
            a[m] = i;//m前面所有的数都不可行
        }
        printf("%d\n",sum);
    }
    return 0;
}
View Code

 

 
posted @ 2015-04-26 15:39  Painting、时光  阅读(431)  评论(0编辑  收藏  举报