ZOJ14省赛3870——位运算——Team Formation

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{AB}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6
大意:取的两个值的异或值大于这两个数,观察发现对于当前数来说,只要存在数比他小一位并且这一位&值为0就满足,所以就先预处理,把位数都处理好,然后搜最大位数,接下来只要找有小于这个数的就行
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[100005],b[35];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        int n;
        long long sum = 0;
        scanf("%d",&n);
        for(int i = 1; i <= n ; i++){
            scanf("%d",&a[i]);
            for(int j = 30; j >= 0 ; j--){
                if(a[i]&(1<<j)){
                    b[j]++;
                    break;
                }
            }
        }
        for(int i = 1; i <= n ;i++){
            int j ;
            for(j = 30; j > 0 ; j--){
                if(a[i]&(1<<j))
                    break;
                    j--;
                }
            while(j >= 0){
            if(!(a[i]&(1<<j)))
               sum += b[j];
               j--;
           } 
        }
        printf("%lld\n",sum);
    }
    return 0;
} 
View Code

 

 
posted @ 2015-04-26 15:10  Painting、时光  阅读(166)  评论(0编辑  收藏  举报