POJ3267——DP——The Cow Lexicon

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L 
Line 2: L characters (followed by a newline, of course): the received message 
Lines 3..W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source

大意:找到串使得能在字典中找到(可以忽略一些)dp[i] = min(dp[i],dp[pm]+pm-i-len)比较难想到,具体看U神,超详细~,
#include<cstring>
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX = 1000;
char s1[MAX];
char s2[MAX][400];
int dp[MAX];
int main()
{
  int w,l;
  cin >> w >> l;
  cin >>s1;
  for(int i = 0; i < w;i++)
    cin >> s2[i];
  dp[l] = 0;
  for(int i = l - 1; i >= 0 ;i--){
    dp[i] = dp[i+1] + 1;
    for(int j = 0; j < w;j++){
        int len = strlen(s2[j]);
        if(s2[j][0] == s1[i] &&len <= l - i ){
             int pm = i;
             int pd = 0;
             while(pm < l){
                 if(s2[j][pd] == s1[pm++])
                    pd++;
              if(pd  == len){
                dp[i] = min(dp[i],dp[pm]+pm-i-len);
               break;
               }
             }
           }
      }
    }
    printf("%d",dp[0]);
  return 0;
}
View Code

 

posted @ 2015-03-24 20:27  Painting、时光  阅读(100)  评论(0编辑  收藏  举报