POJ1068——模拟——Parencodings

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

题意:括弧编码,模拟,将左括号看作-1,右括号看作1,然后搜为1的再向前找为1的值有几个,即右括号有几个,记录下来就是答案,详见代码
#include<stdio.h>
int main()
{
    int a[1000],b[10000],c[20000],i,j,n,m,k,e;
    scanf("%d",&n);
    for(e=1;e<=n;e++){
        scanf("%d",&m);
        for(j=0;j<m;j++)
            scanf("%d",&a[j]);
        //将左括号定义为-1右括号定义为1
        for(i=0;i<2*m;i++)
            b[i]=-1;
        for(i=0;i<m;i++){
            b[a[i]+i]=1;
          }
 
        /*for(i=0;i<2*m;i++)
            printf("%d ",b[i]);
        printf("\n");*/
        //找到为1的左边为-1的数大于1的数的那个值
        int p=0;
        for(i=0;i<2*m;i++){
        int count=0;int flag=0;
        if(b[i]==1){
 
                     for(k=i;k>0;k--){
                      flag=flag+b[k];
                       if(flag==0) break;
                       else if(b[k]==1) count++;}
 
 
                    c[p]=count;p++;
             }
           }
      for(i=0;i<p;i++)
        printf("%d ",c[i]);
        printf("\n");
    }
      return 0;
}
View Code

 

posted @ 2015-03-04 16:21  Painting、时光  阅读(112)  评论(0编辑  收藏  举报